Vivokey not connecting with Fidesmo app

I can’t connect the vk with the fidesmo app, gives me an error every time. Tried it on multiple devices, same output. Then I tried the file from github, to try it on desktop systems. Ran through multiple java versions from 11 to 19, Win 7/10/11 pro and a couple of Mac systems. The fidesmo app closes instantly, after starting - gui and terminal.

So… What now? Anybody any idea?..

Are you talking about an Apex implant?

Edit: just saw you posted in the Apex section: ignore :slight_smile:

Please provide more information.

(1) What do you mean by “The file from GitHub” and “Fidesmo App”? Is it GitHub - fidesmo/fdsm: Tiny Fidesmo command line client in Java ? That is a command line tool which requires a USB NFC PC/SC reader.

(2) Which devices did you try it on? Phone model, operating system version?

(3) What is the output of the Fidesmo App on the phones you tested?

(1) Yes, i tried the jar file on different OS. I finally found help, the —reader output was

Card communication error: SCARD_E_NO_SMARTCARD

(2) iPhone X, 12, 13, all with the latest iOS. Three different Samsung, don’t remember which models.

(3) it’s not connecting at all

Please enable debugging logs in the Fidesmo app. Go to the app settings and enable:

  • Show debug data
  • Enable local logging

Then report any errors that pop up.

I suspect the alignment with the reader is not good enough to enable a stable connection, also see flexSecure Java Card basics / app install - #7 by StarGate01

1 Like