xDF2 DESFire EV2 8kB NFC, read/write working for 2 days, then stopped after plane flight

I had my chip professionally implanted, the chip has now rotated horizontally.
My phone can not pick it up nor can an ACR122u-A9.
I have tried multiple apps, ive tried the debug app, ive tried putting the ACR into my phone and still no read whatsoever of the chip. I’ve tried to wipe it, format it, everything and it is not being even slightly recognized. It worked for the first 2 days, i could read/write whatever i wanted, after i got off my plane it died. it has been 10 days so far and still nothing, no read at all, I am going to place a flexDF2 into my arm later this week and trial that out instead. If after 30days the XDF2 doesnt work i will get it removed and ship it back for testing by dangerouthings things. Any ideas on what could of gone wrong? any recommendations? it is not even seen as a nfc chip on any device, and i can physically by making a fist push it up onto my skin and see it and feel it. so its there and within what should be read/writable range but still nothing. I am unsure if i may of bricked it, but even if i bricked it it should still read atleast by an nfc reader.

On initial reading of that, my thoughts were
Immediately after Install there would be minimal swelling = good reads
2 days later increased swelling can cause read issues
Plane flight causing edema thus further reducing read range

The rotation can happen, and reasons vary,
How long after install did that happen?
Did you take any prenatals?
Are you <25yo?
Did you tape or corral the xDF2 in place?
Were you “overly” active with your hands within the first 2-4 weeks?

Then the more I read your post, 30 days, that doesn’t sound good.

I think you shipping it back for testing by DangerouThings things is an important step in the diagnosis and if you haven’t contacted DT yet, Amal will likely see your post here and have questions and suggestions for you.

To me, Nothing you mentioned, sounds like it could have been the cause of a failed implant.
I have made many flights and scuba dives, with no adverse reactions, so unlikely it is a pressure-induced issue, this is likely due to the fact the xSeries implants are resin files, and therefore no air voids to act upon; plus Tests we've performed on our x-series tags

It will be unlikely that your new FlexDF2 will rotate due to it’s form factor.

I have 22 years old, it took 2 days after install for the device to stop working, it was implanted on 11th of September 2020, swelling went down after 5 days, it rotated after 3 days i think, i did not tape it, i have not been active, i am cyber security researcher so i type a lot, but i was on vacation so i didnt get much of a chance to type, the most activity i had was holding a beer. After 30 days, if i still get no read, i will ship it back. and ive also emailed amal for advice.

1 Like

I’d try to write a url to it.
The only thing that comes to my mind is that it is not formatted… but idk.
Doesn’t sound good.

Before you take it out I’d get a proxmark and hop on the discord to try some things!

1 Like

Here are some photos of the site and myself trying to scan it with a reader, confirmed reader works with an nfc ring, tried samsung galaxy z flip and samsung s10 ontop of this as well.

@yeka as for formatting goes, which application should i use, what exact amount of bytes etc should i use. XDF2 says 8KB but i remember reading somewhere its 7876 or 7678, unsure.


I’m one of those that use NFC Tools.
Others will probably say TagWriter.
Idk about bytes, just use https://dngr.us that should fit :wink:
I imagine you just write a url and the app will format the xDF2 to NDEF automatically.

it is not even being recognised, no “nfc tag” errors from android, no beeps from the ACR, nothing at all. I have tried to write the url, using multiple different angles, pressing down, being light, etc on the back of my phone with tagwriter, still nothing.

I have tried: TagWriter, TagInfo, NFC Writer, NFC Tools PRO, NFC Tools, Mifare desfire Tool, Dangerous Things Support tool, and ACR 122u NFC Reader Utils. Including using the format and change to NDEF on all of the apps that support that.

1 Like

flexDF2 DESFire EV2 8kB NFC - I will have implanted sometime this week.
xSIID NFC + LED Implant - I will have implanted in the near future.
NExT RFID + NFC Chip Implant - I will have implanted in the near future.

Will provide updates on what happens with those as well.


Sounds like you should get a proxmark… some smart people on the discord should be able to help/diagnose further.

can you link me to where i can buy a “proxmax”, i can’t seem to find exactly what you are referring to. dont want to accidentally buy the wrong thing.

ProxMark: https://www.ebay.com.au/i/283995363907?chn=ps&norover=1&mkevt=1&mkrid=705-139619-5960-0&mkcid=2&itemid=283995363907&targetid=919947811646&device=c&mktype=pla&googleloc=9070911&poi=&campaignid=10101785183&mkgroupid=102311926220&rlsatarget=pla-919947811646&abcId=9300368&merchantid=118962942&gclid=Cj0KCQjwnqH7BRDdARIsACTSAdvLNLlIwyyWTBMPLLZG4Hg6sK1nXtjD66xncW-eiB4Ej9zsiM5NX7caAuXsEALw_wcB

Where are you based? Maybe you could see if there are any other members with a Proxmark around so you don’t have to buy it. The thing is crazy powerful, but also quite expensive.

Europe: https://lab401.com/
USA: https://hackerwarehouse.com/

If you do decide to do it, I would recommend picking up a ProxLF antenna up as well, it is designed to work specifically with implants.

Edit: just saw you are from Adelaide. I don’t know any place that sells the Proxmark there. @fraggersparks is based in Brisbane

It is possible the chip has decoupled from the antenna inside. Can you move your hand down the acr122u so your chip is positioned and oriented like this;

In the position your hand is, shown in the picture, would not likely get a reliable read on the acr122u.

Sorry to derail, but Amal, isn’t it 3:15am in Seattle?

I cant find the aliexpress link for the proxmark clone. It’s like 40 bucks, maybe someone here finds the link.

1 Like


1 Like

Poopy diapers know no not the human concept of time.


that was an example, ive manguled my hand in various various different ways, just tried it your way as well, ive moved the reader around my hand left right upside down every angle i can think of, still nothing

1 Like

I live in South Australia, Australia. Looks the same as the one on ebay that is in australia, so i’ll buy the aussie one first. if we are all in agreement that it is the same device.

That makes me sad. I think it’s possible the chip has become decoupled from the antenna. If you can’t get a read with the acr122u then it’s likely the case. I’m very sorry about that… we can send you a replacement, just use the orange help button on the website and submit a ticket with your order number… or just reply to your order confirmation email with details and we’ll get it sorted.

1 Like