Xmagic problem after MRI

Hi,

Digiwell couldn’t help me, so the recommended mo to write a post over here. Hopefully I’ll get my issue solved here.

I got my self a Xmagic implant as a treat to myself last year. Got it implanted in September -23.

At my work (a school) we got both 125 khz and 13.56 readers. The 125 khz frequency in most of the buildings because it’s the old once, but the 13.56 is installed on new buildings around (yes, most ppl are annoyed due to dubble fobs).

Well, the 13.56 frequency is also used at my local “gym/swimmingpool”. So the administrator at my work helped me to set my chip up so I could use the implant.

Now to the problem. Last Monday I had to get an MRI due to nerv damage’s in my back. The MRI was at 1.5 Tesla. The MRI focused at my back around chest height.

The problem after that is that the 13.56 chip is really hard to read. Never had this issue before until now. I noticed it in Tuesday at the gym, it didnt work on the check in, but it worked at the register. I later went to work where it barely read. It took me about an hour to reset the chip, but it didn’t help. The 125 khz works perfectly as before. But the 13.56 chip is struggling.

Does anyone have any idea of what I can do? I’m not really fond of the idea of taking the chip out (needles aren’t an issue, but taking it out feels scary :joy:).

Thanks in beforehand!

It’s possible that the MRI affected the ferrite core of the antenna and the xMagic. The good news is, this is not permanent. You can simply wait and it should improve over time, or you can try holding your implant within a 13.56mhz reader field for an extended period of time… perhaps a few minutes… and it should help resolve the magnetic domains in the ferrite core.

4 Likes

Thanks for such a quick response!

I’ll try it out next week at work, the admin has a more powerful reader / writer i can use.

2 Likes