Xsiid wont read or write

I have an xsiid blue led in my hand and just recently it stopped reading or writing with NFC tools app.

If I’m on the read page of the app, it says approach an nfc tag and when presented, my implant will light up, but the app will not respond or read.

Additionally, it is the same story with erasing (have NEVER attempted to lock the tag) or writing. No response from the app.

The last thing i attempted to do with it was write a text file to my implant.

EDIT: of the posiible things i attempted to last write to my implant were:
Text file: total 73 bytes and
File link: total 420 bytes
(Separately, not at the same time)

I’m worried i did something to accidentally brick my implant that is now in my hand.

How long have you had it?

It was installed about a month ago.

I ordered it and it arrived around early february of 2023.

I also read here that these implants are factory lock protected and i did remember when i first got it it did scan and went to the dangerous things URL.

A month is a bit long but it could still be the swelling from the install. Sometimes it’s not visible but still there. Can you try with other phones/apps?

Ill have to look into other phones/devices but i have tried taginfo and tagwrite as well and same problem. I cant even get the info dump from the tag.

Did you hit/play around with it? That could make the healing period longer.
If you wrote ndef to it you probably didn’t brick it and glassies don’t fail very often so the most likely is a pocket of blood or swelling or something like that.

Have never attampted to write ndef but theoreticaaly is that easily fixable for a newbie?

It was scanning just fine just a couple of hours ago and the led is as bright as can get when i posted originally

You used “add record” right?

That’s NDEF
On tag writer they’re called datasets

Yes I used Add record, then whatever i wanted (i usually put a yt link to rick roll people) then write, approach nfc tag, and it would write.

1 Like

Sounds good, I don’t think you can brick it by doing that. I think the best thing you can do is to avoid disturbing the implant location too muche and wait a week or so for any inflammation to go away. Btw how deep is it? Can you see it’s shape through the skin?

Yes i can see it somewhat easily in my skin.

1 Like

You really can’t brick the xSIID unless you authenticate first, then change some of the config data in the last pages of the first sector (first 1kb). What you can do is mess up the NDEF record in certain ways that make it hard for iPhone and in some cases also Android to read or so anything with it… but you can fix these types of issues, generally speaking. For more info on this, check out;

When it comes to the xSIID lighting up but not reading, the bare minimum I can tell you is that the chip and antenna are receiving power from the phone. The LED gets power from the chip’s power harvesting outputs, so there is no functional problem with the chip or antenna. This is a coupling / performance issue, or a fixable issue with memory configuration.

I would try using the Dangerous Things Support Tool to try to write a blank NDEF record to the xSIID;

1 Like

Ah hell, i guess s22 ultra is too new for the support tool. I get the “this app was made for an older version of android” message.

You should still be able to open it though after seeing the message right?

Download button isnt even appearing. This is in play store

Still no response from tag or phone

This feels like a coupling issue. The LED will consume power from the field before the chip has enough power to communicate.

Is there a case on your phone? Do you have any other readers you could experiment with?

I dont have any other readers on me. I do have a case on my phone but its very minimalistic and thin, i even tried taking it off.

Hmm ok. Have you tested the absolute best orientation on your phone using a field detector keychain?

Anyone else have a different model of phone that could be tested with?