Apex Flex + iOS app problems


We have alerted Fidesmo to this issue as well. I can confirm on iOS the connect service button still just never appears. Manual delivery works however.


Are you able to help walk through the steps? Here is what I have done.

Enabled Manual install on the Fidesmo App.
I connected my Apex flex.
Clicked the “Manual Delivery” button in the upper right.
Put in the App ID and install for Service ID.
I scanned my Apex flex Again
I got the “Finished” Installation Successful.

Then I’m lost as to what to do next. (also on an iPhone)

That should be it if you got the finished installations successful message. There is nothing more to do locally. Move to the Tesla and follow the pairing instructions as if you a setting up a new card, which in essence you are as far as the Tesla is concerned. You will need a current authorized card to complete the pairing process.

Optional: change the device name when completed.

Gotcha! 2 more quick questions if you’re cool with that.

  1. So there is nothing you see on the Fidesmo app?

  2. I’m getting my 3 next week, do I need to wait to install the apex or do I just put my arm where the keycard would normally pair?

Nope, nothing else to do with the Fidesmo app. It just facilitates the installation of the applet on the Flex.

I would assume the keycard is in the same location as the MY. Near the cup holder area. If so, yeah just put your arm there. I found the internal reader was much easier to trigger. If it’s a new install of the flex, any swelling may inhibit communication until it subsides. If it’s been a bit, I would not anticipate any trouble scanning.

This topic may be helpful too. We talk about the reader and some intricacies with its use. Orientation of Apex Flex?

Congrats on the 3. I will never go back to an ICE unless they pry my Tesla out of my hands. Haha


Awesome!!! Thank you so much. I installed the NAC it a few times thinking I should see something in the the app so hopefully it didn’t mess anything up hahaha

No prob waiting for the swelling to go down just wanted to ensure I wasn’t messing anything up.

Appreciate the help!!

1 Like

Hey, where can i find all the application id’s?

This one has the fido…

Wanted to check to see if there was any update on iOS? I tried the NDEF Emulator applet with the manual install and it’s not working. Best to go get a burner android just for Fidesmo? or do we think it will be updated and working soon?

This is only my supposition, I know nothing more than you…
I think there is a lot of work going on in the background with many things in the works.
I imagine, the iOS functionality will be one of the priorities, but I have no idea of the timeframe.

So in my opinion, you might as well just wait it out, there is no reason for Vivokey to not launch the iOS fix/ update, so as soon as it is ready, it should be released.

The way I see it, is
Those of us lucky enough to have an APEX mega or Flex are in a middle ground, We have early access to things that are already in place, we have the implants in and healed, and as new things come online, we get immediate access to it. We just have to remember, the APEX has not yet been officially launched and is still a product under development

We are the lucky few…


Love it! Great perspective as well. The NAK works well; if that’s all I ever used it for, I’d still be very happy! (I still owe a video).

1 Like

Can you explain exactly what you mean by this?

I’ve tried installing all of the apps listed in the screenshots except the NDEF applet, through the manual install method.

The OTP and HMAC applet seem to install ok but neither work correctly for me. I can’t install the PGP applet, just fails to complete every time. NAK working fine however :man_shrugging:t2:

I’ll have my android phone on the weekend so will try with that one instead and see if there is any difference.

Sorry to clarify I haven’t tested the HMAC applet but the OTP doesn’t seem to work.

@amal I tried to add the NDEF Emulator applet through Fidesmo manually using:
App ID: 61b4b03d
Service ID: Install

When I initiate, it fails immediately, even before I can scan my Apex.

I believe there is some sort of companion app in the pipeline that is needed in order to fully set up the hmac-sha1 applet so that is why that one does not work for you yet.

Otp applet should work but not sure about ios in specific. Are you using the vivokey authenticator app with it?

Tested OTP applet with the Yubikey Authenticator app on Windows and an ACR AC1252 reader so nice strong NFC field.

It works with my Yubikey 5C NFC but not Apex.

Yes, but I believe you need to use the vivokey authenticator app with your Apex though, and not the yubikey app :blush: