ChipscanLibTester crashes

Are these endpoints still active? Using my Arduino I am only receiving 502 errors. I am also trying to use an unedited(other than the apikey) chipscanlib-demo Android app with no success. When the ‘get challenge’ button is pressed the app responds “challenge received. Waiting for tag…” I do not believe it because the app crashes whenever I scan my spark 2. Could anybody confirm these problems?

@fraggersparks is probably your best bet…

1 Like

They should, but they aren’t, I get 502 aswell.

1 Like

I was getting that a couple weeks ago chat with @fraggersparks he fixed it for me

Hm he said it was a reboot that fixed it? Strange.

Yeah I think the server hosting the api stuff needed a slap.

1 Like

It sometimes doesn’t reboot after updates.

It’s very late for me tonight, I’ll put a boot up its virtual backside in the morning.


Thank you @fraggersparks I am now receiving challenges from get-challenge! Sadly, I am still having problems receiving a response from the pcd-challenge endpoint.

The chipscanlib-demo app for android no longer crashes when I present my spark 2, instead nothing happens. My phone will vibrate whenever
I present my spark 2 but the app does not react; it continues to say “Challenge received. Waiting for tag…”

Thanks for your time!

1 Like

Can someone else confirm that the Chipscanlib-demo app for Android is non-functional?

I cannot tell whether the issues lie with the server endpoints, which only Vivokey can fix. Or if the issues lie with the demo app’s compatibility with my phone, which I would have to fix.

Any help is appreciated.

Edit: Specifically Spark 2 if that matters…

I’ve looked into it when you asked. It doesn’t work for me either.
I didn’t get too far with finding the issue, but I’ll give it another shot tonight.


I cannot tell whether the issues lie with the server endpoints

I don’t think so.

Or if the issues lie with the demo app’s compatibility with my phone

I don’t think so either.

For me it crashes instead of freezing. AFAIK it crashes after having validated the response. I modified the app a lot, it shows the get challenge button before crashing, and the auth doesn’t return an error, so I assume the server part is okay. And since it also crashes on my 2 phones, I’m sure it’s not a you problem.

I suspect it’s to do with the thread stuff, cuz that’s the only thing I could crash the app with, but no matter what I uncomment or only run once, it crashes, so maybe it’s in chipscanlib after all. (Another argument for that would be that the app has worked before and it hasn’t changed lately, has chipscanlib changed though?)

I give up for today.

1 Like

For anyone who can offer support, I would like to refine my statement that “nothing happens” when I present my spark 2.

ChipscanlibTester actually crashes around 20 seconds after I present my tag. Contrarily, the app does not crash if I only press the GET CHALLENGE button and do not present my tag.

Yeah that’s what I mean by “it crashes after having validated the response”. I actually checked that, once auth.isFinished() it crashes but auth has no error.
The thing is, there’s no bug after if (auth.isFinished()… it crashes even if the code is removed. I suspected maybe it reads the Tag twice but no that’s also not it. I’m kinda out of ideas.

My suspicion is that there is a null response from /pcd-challenge. I have no proof that this is happening it’s just where my Arduino code errors out, so it’s my best geuss.

I was only attempting to use ChipscanLibTester to verify that the endpoints offered to the devs work. Sadly, ChipscanLibTester must be out dated…

I just had my first successful run of ChipscanLibTester!

Bonus: I didn’t have to change any code, it just magically started working!

Edit: I’m realizing I now KNOW there is something wrong with my Arduino code…

I did not realize @yeka is employed by Vivokey until it was publically announced yeka was “testing.” Thank you @yeka for your diligence in getting this app back in working order. I did not mean to refer to your hard work as “magic” though from my point of view, your skills behind a keyboard are magic. :+1:

lol I’m not employed by vivokey.
I did not fix the app, it indeed magically started working again for you, it’s broken for me.

1 Like

Wow. My mistake. I’ll still say thank you to you for helping me bring attention to this. I geuss the fix must have actually been magic then. Especially since it only works for my phone(Nubia Redmagic 5g)

Maybe the problem is the user agent string? Is there possibly a requirement that isn’t listed in the documentation?

I’m not sure anymore.

I’ll have to look at the traffic to figure out what’s happening. At least when I tried it last time there wasn’t even a requirement for the content-type so I doubt it.

This is a weird bug, but I kinda doubt it’s serverside.

I think the server needs another kick in the pants please. @fraggersparks