Connect Android to Proxmark Easy?

Great first post @fusion

WELCOME to the community

Thats because I wanted to, not because Discourse told me to


Hello geniuses, good afternoon.
My reason for why I write here is because I bought a pm3 RDV4 thinking that its handling was simple, as well as connecting to the phone and starting to work … when I got it I found a wall and I collided with it hahah.
Good! the fact is that since I don’t know how to use it and after having tried to follow all the instructions, I can’t do anything. I need to know if someone from here in this forum can help me install or teach how to use the device with android. Without a doubt I am very open to paying economically for teaching.
I hope some response from any of you, because from what I see some of you are already masters in the use of proxmark3.
greetings to all

are you on windows or mac or do you want to try to use it with your phone? if phone only, iphone or android?

in short, you will probably want to start out using it with a computer or laptop first… get it working there… then try for the phone.


What Amal said above, Plus Linux could be an option.

Make sure your Easy is running on 2.0, I don’t think android plays nice with Icemans fork

I am using a Proxmark3 Easy and have so far tried it with Linux, Windows, and Android.

As I bought from DT it came labelled as having Iceman RRG firmware v4.9237-1270-g65478867.

I got it working with the latest client on windows using Proxspace and following the instructions at

I then switched it to a Linux box, fetched the github branch (again) and it worked.

Finally I tried it with Android, I tried Walrus first (it didn’t work) but Walrus seems to need a mainline firmware.

I then switched to RFID-Tools from RRG. This asks what device you are using, I selected Proxmark3-RDV4 and it quite happily talked to the Proxmark3 Easy.

As for the android hardware, I am using a moto g7 running Android 10. This has a USB-C port on it, I used a Male USB-C to Female USB-A adapter and the cable that came with the Proxmark Easy.

I hope that this is of some help to others.


That is some great info, Thanks for sharing :+1:t3:

1 Like

I will also add that Termux works on a Google Pixel 4a 5G (unrooted), latest RRG / Iceman fw on a pm3 easy using the TCPUART bridge app linked in Android · Proxmark/proxmark3 Wiki · GitHub.

1 Like

Thanks for that.

I haven’t tried it in termux yet (although the reg app also includes termux).

I should have added that my phone is also unrooted (and has no nfc capabilities)

Hey can anyone point me in the right direction? I have an android tablet and a chrome book and it’s been a struggle to get my pm3 easy to even work at all. I would love to know what devices work well. So several ppl here claim that their pm3 works with a cellphone??? I don’t want to have to buy a rdv4!!!

Yeah I just tried that using a double sided usbc cord on my android tablet, didn’t recognize my pm3 easy. I’ve tried andprix and rfid tools

What firmware is on the proxmark3 and are you sure it’s compatible we with the android client?

On the box it said 2.0 and above, so I don’t know if there even is anything installed. Sorry but I’ve been a Mac person for years and decided to introduce myself to android by learning this complicated ish. Sorry guys I’m a total noob but I’m trying!

Did you buy it from us or somewhere else? If it’s from us we actually loaded the iceman firmware on it.

I did not buy it from you guy. I found one on Amazon, further proof of me knowing nothing

You might try “walrus” on Android and see if that will talk with it. It requires a “mainline” firmware on the proxmark3.

If possible you might return the unknown proxmark3 to Amazon and purchase one from Dangerous Things. I purchased mine from them and am very happy with the package and the assistance I have received on here.


Ok I have been pulling my hair out contemplating my own demise over this god damn pm3 “easy” (fml). I am at the end of my rope. If someone could tell me an affordable device that is comparable with this damn machine that would be super cool! Thanks!

Define affordable. I don’t know which Proxmark3 you have so I can’t say for sure what the problem is. If it is a Proxmark3 Easy then I have had success with the iceman firmware and the RRG RFID-Tools. If you don’t know what firmware you have you might want to consider returning the Amazon one of unknown provenance and purchasing

That comes with a fairly recent version of the iceman firmware on it and should work with

1 Like

I have an unrooted Galaxy Note 10 Plus with a Proxmark3 easy (Iceman) and I installed RFID Tools. I can find my Proxmark3 but I get this error message