DangerousThings Pm3 stopped working- aliexpress model works fine

Hi all, I finally received my new PM3 Easy from Aliexpress after a long, tiresome, and costly attempt to bring my DangerousThings PM3 Easy back to life. After plugging it in and updating the firmware, it worked great! No issues. So maybe somebody can tell me why a generic PM3 Easy from Aliexpress that I spent about $30 dollars on is working fine running the same firmware, using the same USB cables as the over $95 dollar DangerousThings variant that crapped out on me a couple months ago. I chose DangerousThings for my first PM3 because I trusted the brand and didn’t want to be troubleshooting for ages just to make my product work. And since I got it back in February of 2024 it’s been fine- up until the mid-end of April. Ever since then I’ve been getting “USB Device Malfunctioned” warnings on Windows, no recognition of the USB device on lsusb on Linux, I’ve tried multiple KNOWN GOOD usb cables, Xubunutu, Mint, Windows, Mac on MULTIPLE USB PORTS in MULTIPLE physical machines. It’s the same story every time-

As soon as I plug it in, all the LEDs turn on and hold steady. This lasts for around 5 minutes before SOMETIMES turning off. When this happens there is then about an 80% chance that even if the PM3 client detects the device- when I run a command it times out, Data Graph buffer something something ran out of space. Basically the device is detected, but clearly something is wrong and it’s not able to communicate properly.

I’ve been able to update the firmware, both with and without holding the side button. Bootloader, fullimage, flash all, etc.

So now that I have a new device, it’s very very very hard for me to justify all the hours I’ve spent troubleshooting without success when a different physical unit with the same USB cable, same firmware, same machine just works fine. I even unscrewed both to look for differences and the soldering on the aliexpress unit actually looks a little cleaner, while the rest looks identical. Actually, theres some excess flux and gunk under the THT pads on the microusb port on the PM3 from DT, though the pictures I took don’t show this, but I can add them if needed.

Attached are images of both. The one with the blue tape is from DT, and the one without is from Aliexpress.

They look nearly identical sans a few differences in some of the printing on a few chips and the silkscreen component labels.

Overall this experience has sucked lol. I used to use my PM3 consistently (a few times a week for a few months) until one day it wouldn’t connect to my laptop. I then had to use my Flipper as a backup which thank god I had, but was a bummer in comparison. I know this post is kind of salty and bitter and I’m sorry, I’m a little frustrated with this and troubleshooting sucks. It especially sucks when the conclusion you come to is that it’s a hardware issue. I’ll of course be tracking the life of my aliexpress board. Maybe it will expire in the same amount of time and need replacing. But at the end of the day, I think most of you would rather spent $30 bucks every few months than almost $100.

Final words are that- MY PM3 IS NOT 100% BRICKED. Well, it may as well be bricked. But it connects EVENTUALLY, and SOMETIMES works. It’s not completely fried so I still have some hope. But it’s above my pay grade at this point. I don’t want to reflow solder joints or swap chips or whatever to try and get this to work. I don’t even really want to JTAG it but perhaps that’s the next step. Maybe it won’t be necessary and if I send it off the someone else they will get it working after 20 minutes and I would be happy to be proven an idiot, but I’m about at the end of my troubleshooting journey. I don’t really have any wishes for what comes out of this. I guess ideally I could mail it off to someone and have a third party take a look and sanity check me.

I appreciate your feedback and suggestions, and thanks for reading my rant.

This feels like a component overheating or a passive going out of spec.

Reply to your order confirmation email to open a ticket and we’ll get you sorted out.

1 Like

Thank you, I will!

Some more good reasons that you may not know about, is the fact that the Proxmark3 from dangerous things aren’t just transshipped. They are installed with ice man firmware, which is a good head start for people that don’t know what they’re doing, on top of that, there is also the connections that Amal preventivly resolders. That is probably the difference in the soldering that you noticed but most of all the reason to buy from dangerous things is

This, :point_up: and that’s why there’s a whole thread dedicated to the customer service from dangerous things.


This alone is worth the extra bucks imo… I’ve had them break off before.


Yep, so far going great and well appreciated.

1 Like

there’s also a factor that need to be considered
we all stand on the shoulders of the people who came before us and there efforts and that should be thought of when possible
pm3 hardware is open source which makes the financial barrier of entry low and promotes the free flow of knowledge. thats great and i don’t think anyone will judge you for going that route.
as for me i don’t mind spending a couple extra bucks supporting creativity and experimentation that interests me
p.s. you cant eat knowledge