eGeetouch Smart Travel Padlock


#1

Continuing the discussion from Product Compatibility List:

I buy it, but i cannot use my xNT.
On configure option i can create a new tag but i need input TAG ID. The tag id i 4 alpha (ex 3D93 < the litle tag join with che padlock).
If i read my xNT i find only the serial numer (7x2 hex)
Thank you
Gianni


#2

Reading the post about compatibility i buy also one Smart Padlock but i find the same problem.
The tag ID (join with Padlock) i 4 alpha (61FA or 1A22).
Eh ere can i find the same ID of mi xNT?
Thank you
Gianni


#3

I had the same problem - I ordered it from amazon.de. You need to synchronise the lock with your phone - it doesn’t work. I write to the support from egeetouch. The answered me, that amazon sold the old locks - and they are not compatible with the new smartphones. I write them, that I had the S8+ So I send it back.
I think I will order the lock from the offical website.


#4

Yes… it seems that these locks do not have much process consistency during manufacture… some work, most do not. I will be removing it from the product compatibility list now.


#5

I’m not sure if I have the same problem. I did purchase the eGeeTouch Smart TSA Travel Lock from what looks like an official eGeeTouch Amazon storefront.

The lock has worked flawlessly until the Android phone App updated last week and erased my settings completely and when I logged in to set it up again, I received a message telling me no account exists with my email address. I’m at a loss at what to do now. I created a new account and tried to set up the lock again but I can’t create a new pin number, so it won’t pair.

I don’t have enough cash to buy another until December, so I’m left with no security and the company won’t answer my emails for help.