God I need help with my proxmark3 easy

Ok before you are the first person to tell me to RTFM I read the god damn manual this is after a lot of trial and error.
So I bricked my Proxmark3 Easy, this is fine, I read on using the Raspberry Pi as a Jtag programmer, I read on this forum how to fix it and I followed it to a T 7 to 8 times, and every time I get this weird thing where it appears to have worked and installed the new firmware but it never shows up on any of my computers Thinkpad P50 (Ubuntu), Manjaro Linux (Ryzen Desktop), and my Raspberry Pi, and whenever I use DMESG it does not show. Does anyone have any tips or tricks that I can use?

Pls help.

Hate to suggest this, I get that you’re frustrated, but have you tried a new USB cable? Several people here have had issues with the included cable.

Not showing at all in dmesg is odd.


Also… are you possibly trying to stuff a large firmware like iceman onto a 256MB low memory version of the pm3 easy?

I love you

[17012.399175] usb 1-4: Product: proxmark3
[17012.399177] usb 1-4: Manufacturer: proxmark.org
[17012.399179] usb 1-4: SerialNumber: iceman
[17012.984340] cdc_acm 1-4:1.0: ttyACM0: USB ACM device
[17012.986305] usbcore: registered new interface driver cdc_acm
[17012.986309] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

It was the cable





Glad you got it working!

Might I ask which instructions you followed for unbricking? If they were mine, any feedback?

1 Like

Hi everyone, it’s been awhile since I’ve had the time to play with my Proxmark3, but I was working on it earlier. I have the Proxmark3 from DT and I had followed the full instructions for running the Iceman software and everything. The problem I am having is on HF reads I am getting nothing, as if there is no tag visible to the Proxmark, and LF reads give me communication errors. This is running on a Windows 10 computer and the Com port between the computer and Proxmark is COM6. I have included a screenshot of both reads being tried with known good tags sitting directly on the respective antennas of the Proxmark. I suspect some kind of communication error is occurring between the Proxmark and the computer. The LF side consistently gives me that Graphbuffer error on the first try and then the communication error on the second try. I am just curious if anyone else has ran into anything like this and if anyone has any suggestions on what to do. Possiblity it’s just something right before my eyes that I am missing, but any help is greatly appreciated :+1: thanks :wink:

This link may help…

What type of cards are you trying to scan?

So far both an HID formatted card and an EM4100 formatted T5577 card on the LF side, and a card that contains a Mifare chip on the HF side. The EM4100 T5577 card registers on my access control system and the Mifare card is easily read with NFC Tools on my phone and on the computer with an ACR reader. :wink:

Just out of curiosity. You did not remove the center pcb ? I have found this causes the exact problem you are having when I did it.

Also have you tried on another computer? My windows 10 desktop can do everything but flash a proxmark when it comes to the client. But my laptop is easy peasy no problems.

Can you please take and share a screenshot of when you first connect and run the Proxmark3?

I just want to see if you have a mismatch between your client version and your device version.

or you could try this

Future Updates

( Thanks to @TheCyborgFirefighter and @Zwack ORIGINAL POST )

  • cd proxmark3
  • git pull
  • make clean && make all
  • ./pm3-flash-bootrom
  • ./pm3-flash-fullimage
  • pm3
  • hw tune

Here is a screenshot of when I first load pm3…

There is a newer version available. If you want, try to update to v4.14831

1 Like

Thanks everyone for all the help so far, what I did now is try the latest updates, plus another cable, and another computer. I still get the same thing, even says both antennas are unusable when I run hw tune. I got me really curious about that middle board. I haven’t made any physical changes to the Proxmark since I got it. However, here is a picture of the Proxmark as is. I’m not sure if it will help, but this is how it is physically…

I notice that you have a different layout on your lower board than I do. I doubt that that makes a difference.

You did remember to change the Makefile.platform to generic didn’t you?

@Kdude0 Where did you get your PM3 from?
is it a 512 or 256kb version?

it shows in the SS it’s 512Kb

1 Like

Haha, cheers, and it was only a couple of posts up…:frowning_face:

It was Just a random thought…

That says Dangerous Things to me. In the photo it looks like the side usb port is nearer the top and the button is nearer the HF antenna while on mine the side usb port is between the button and the middle screw. I don’t think that that is relevant but I did find it interesting.