Implant still not working

Hey everyone,

Need some help please, still can not read anything of my implant or see the blue light when ever l try to scan it or write anything to it, when anyone else try’s its the same result. I maybe missing something simple as l no tech expert at all. Any help would be greatly appreciated?

Thank you

1 Like

How long ago was it implanted?

Hi there, a few more questions:
What implant you have?
What readers you’re trying to read with?

1 Like

Looks like a blue xSIID. See previous thread. Looks like it was scanning. iPhones can be tricky–I don’t have one but there’s this video that might help.

2 Likes

I message u privately iPhone can be a pain

1 Like

When scanning with iPhone I find if my case is on it can’t seam to find & scan it but I take my phone out and it helps everything plus the scanning with iPhone is hard cuz it takes a minute to find right spot I got one of the led implants but ago to help when I’m haveing drinks it gets tricky XD

1 Like

in case the issue is with the case blocking too much there are two options for you

and

3 Likes

It was implanted on 24 May buddy

hmm… yeah it’s been a few weeks but there is still a possibility that blood has pooled in just such a way that it’s created a dark spot. My blinky implants in both my wrists took 4 to 5 weeks to start seeing anything, and about 7 weeks for full brightness.

1 Like

Out of curiosity, did you self-install?