Issues with flashing Iceman to my Proxmark3 Easy and a few more problems

Hey there!

As a complete newbie I acquired lately my Proxmark3 Easy (locally in my country - so it’s not the one that comes with Iceman preinstalled :frowning: ). Anyway I got a few problems that I noticed that couple of people actually been having after thorough internet searches. Unfortunately, I am nowhere near to resolve the issues.

I’ll start from the top:

  1. First thing first I wanted to flash the Iceman repo. I had problems with ‘pm3-flash-all’ first so I went through flashing the bootrom first and then went to the fullimage. Beforehand of course I changed the Makefile.platform file to reflect that I’m having Proxmark3 Easy (Checked both - PM3GENERIC and PM3OTHER). The problem that occurred is the same as in this topic: FlexMT HF Reading Issues - which is basically an error writing to 496 block of 518 when trying to flash the fullimage. My Proxmark3 Easy is for sure the 512k version. I went through battles with different cables, I tried swapping the USB ports and even got myself a Windows laptop to go through the process once again - nothing actually helped. I know that there in the topic the OP used JTAG but I don’t have one and I really have no idea what would I be supposed to do with it. EDIT: After trials and error with holding button, different ports and so on - I can use ‘pm3-flash-all’ but with the same results in the end where I can’t write to 496th block.

  2. Anyway I decied to go with the official repo - according to the above thread the OP managed to flash it without problems, so did I actually. Got it working, went through the ‘hw tune’ with resulted in:

Measuring antenna characteristics, please wait.........          
# LF antenna: 24.20 V @   125.00 kHz          
# LF antenna: 34.65 V @   134.00 kHz          
# LF optimal: 34.92 V @   131.87 kHz          
# HF antenna: 33.53 V @    13.56 MHz          
Displaying LF tuning graph. Divisor 89 is 134khz, 95 is 125khz.

After that I pursued with the ‘lf search’ command with my 125khz RFID access card that I have for testing and it in fact detected the card as valid EM410x. Then I thought that I’m actually at home - that I at least I am going to write the EM TAG ID to my clean card that I got in the box. It is the 125 kHz T5577 card so I should be able to write to it in theory. Anyway I copied the ID and went with the command: “lf em 410xwrite //the em tag id// 1” with the clean card put on the proxmark’s antenna. This is the output I got:

Writing T55x7 tag with UID 0xthemtagid (clock rate: 64)          
#db# Started writing T55x7 tag ...          
#db# Clock rate: 64

So I wasn’t really sure what actually happend - thought that it might have went through and I can do the actual “lf search” on my newly written card so I used the “lf search” command and that’s what I got:

NOTE: some demods output possible binary
  if it finds something that looks like a tag          
False Positives ARE possible

Checking for known tags:
#db# Tag T55x7 written with 0xsomehexvalues (different from the actual em tag id from above)

No Data Found! - maybe not an LF tag?

Don’t know what it did like that but the card is still unreadable. And to add something to it - After the above command with writing I have to exit the terminal console of proxmark3 and reconnect to actually be able to do any lf search on the original card again. Without the exiting it says that no data is found.

  1. I thought that I could use the “lf t55xx detect” to actually detect the clean card (at least I suppose that it does that) but I’m having this output:

Could not detect modulation automatically. Try setting it manually with 'lf t55xx config'

The “lf t55xx config” or “lf t55xx dump” or “lf t55xx clean” actually does not do anything worth for me. This is the “lf t55xx config” output:

Chip Type  : T55x7          
Modulation : ASK          
Bit Rate   : 0 - RF/8          
Inverted   : No          
Offset     : 0          
Seq. Term. : No          
Block0     : 0x00000000

So anyway to summrise this prolonged post - I’d like to either flash to Iceman repo - I guess it might be then working out of the box with simple writing to the T55xx chip - which I’m looking for to start with something or to do something about the problem I’m having with writing to the same chip but using the original repo. As I said at the beginning - I am total noob on this so I’m sorry if I understood anything wrong did something not as I supposed to. I’m happy to be guided on this matter. :slight_smile:

I just skimmed your post (sorry after you put so much detail and time into it)
Basically, whenever i see someone having problems with PM3 set up, my standard answer is.

“dont fuck around chasing your tail,
Just start a clean build from scratch”

Amals guide (linked Shortly) is super thorough with heaps of info and explanations is awesome if you want to learn along the way…

I took his guide and made the bare essentiails, set up guide for people who dont care and just want it to work.

So, my suggestion to you is:-

Delete all folders relating to Proxmark/proxspace on your computer, and start afresh.

in this link, you will see a further link to Amals guide at the top, and mine in the “drop down” below it.


IF you get an error STOP, and report back so we know exactly where you got stuck, this will help us to fault find more quickly, BUT if you follow the guides exactly, you should have no issues.

Without further ado

good luck…or wait for somebody to talk you through the setup…in that case, also good luck

Cheers for the reply.

Went through installing Windows 10 on separate PC (I’ve been using Linux so far) and tried to do everything according to your tutorial using the ProxSpace (newest one - v3.10). The problem appears to be exactly the same as with the Linux (except the amount of blocks to write which is higher on Windows in ProxSpace but the block number, on which it stops, is exactly the same) which is:

I had to hold the button through the process because the Proxmark was changing the COM port during the flash (It hasn’t happened on Linux). After failed flash the LEDs are blinking like crazy (Same as on Linux).

Anyway - any ideas? We might go back to the problem with official repo too.