Magic Ring V2 Range Issue

I have a new Magic Ring v2 that I purchased less than 2 months ago and I’m having a rather frustrating issue with it. The range on it is non-existent when worn on the finger and only works within about 1/2 inch when off.

When I first received it, I used it to open my safe the range was amazing. I was probably within 4-5 inches of my safe using the LF band and it popped right open. Now, less than 2 months later, I have to take the ring off my finger for it to work properly.

I purchased the Proxmark3 Easy along with my Magic Ring v2 to program it. I have confirmed the range issue using the Proxmark3 and the lf search command. The Proxmark will not recognize the tag without taking the ring off my finger. I’m relatively new to all of this so I apologize if I’m missing something obvious.

If anybody could help me determine if it was something I screwed up with the Proxmark when programming it or something else I would really appreciate it.

Is it a battery powered safe?

Range degradation is more likely to be a reader issue.

Can you put in fresh batteries and try again?

That was my first thought too and the first thing I did. The safe is primarily powered via a cord but has a battery backup and just to be sure I replaced the batteries in the safe and was still having issues. I also tested the safe with the silicone RFID bracelets that come with it and they worked without issue.

As I said previously, the Proxmark can’t read the LF tag on the ring while it is on my finger. If I take it off my finger and set it on the Proxmark, it reads the LF tag without issue. I’m a software engineer so I’m open to debugging this I just don’t know where to start since I’m new to RFID.

that is extremely strange… i could understand going from functional to not working but just a reduction of range… that’s a very rare failure mode.

reply to your order confirmation email and mention this thread and we’ll arrange an exchange.

2 Likes

I’m having the same issue. Ring worked for two weeks and now I have to remove it and physically touch it to the rfid pad to get it to function. It’s a range issue with the ring. None of my other rfid tags are malfunctioning. Did you ever get your issue resolved?

I came here because I’m having the same issue. I got my ring at the start of Jan. It worked ok for a while, then it became very flakey. I contacted support on the 13th of Jan because I had to take it off and hold it against the reader for it to work. I got a response from Amal suggesting I test it with lf tune on the PM3. I ran some tests and made some notes

Baseline reads;
No chip present -> 21750 mV / 21 V / 22 Vmax 
Regular card -> 6410 mV /  6 V / 22 Vmax
Ring reads;
Vertical (centre of antenna)-> 21750 mV / 21 V / 22 Vmax
Vertical (offset closer to antenna) -> 21656 mV / 21 V / 22 Vmax
Horizontal first register (10mm from surface) ->  20556 mV / 20 V / 22 Vmax
Horizontal touching reader -> 19464 mV / 19 V / 22 Vmax

The key takeaway here is the voltage drop from the ring is miniscule when you take it off and non existent when you wear it. The baseline using a regular card you see 21750mV drop to 6410mV. It’s pretty obvious the ring is not doing it’s job!

I sent the results to DT support but they have not replied, not a peep! I followed up a couple of times, but not a word.

It’s easy to imagine they know some rings are dodgy and are trying to avoid contact with customers who get the bad ones.

I think a replacement or refund should be offered! Its not acceptable to sell a product that doesn’t work and then hide when the customer puts their hand up.

@amal @tac0s

I can guarantee you, this is not the case.
Infact, yours is not the only one, But Amal was only just made aware of the issue 4 days ago, so there is no underhanded tactics at play here.

7545c37a-0def-4c89-b4a3-237c35b8fd30_text

I understand your frustration. but trust me, just cool your jets, You will get looked after.

4d1209c2-9aa1-4909-a042-27c90085dcc1_text

There is currently a management and responsibility shuffle around happening in DT.
It’s just unfortunate timing for you.
It may have just fallen through the cracks, it’ll get picked up, and you’ll be sorted in no time.

Read this whilst you wait, Itll make you feel better

2 Likes

ahh i found your ticket in the proverbial limbo and replied. we will exchange it for you and i will post analysis of thr return here on the forum

5 Likes