NExT invalid tag error whenever I scan it

You have had several people say “Give it a week or two for the swelling to go down”… That was a week ago. Perhaps you could give it another week.

I don’t know why swelling would cause it to read in one app and not another

If swelling is causing poor reads (which it can) then one app might be doing more checking against the expected format than another.

One app just says “I read this” the other is saying “I read something but I have no clue what it was”

Do you have any (not implanted) tags that you could use to test the apps and phone?

I had trouble reading a couple of low frequency tags I have until I realised that they were blank. Once I had written something to them I could read them. I am not saying that that is your problem, just an example of how things don’t always work the way you expect them.


Probably doesn’t help, but the vivokey spark 2 in my other hand was put in the same day, and I can scan it just fine

I’m sorry, I know it’s hard, but patience really is key here.
My suggestion would be to wait another week, or maybe even a little more. Swelling can absolutely make weird shit happen with reads, even different results in different apps.

My guess would also be that this one is implanted a bit deeper them the Vivokey Spark 2 you mentioned, and in that case can swelling can make even more of a difference.

If it really turns out that its not working there is practically no difference in removing it now or three weeks later. And I’m sure in that case DT will do their best to make it right.

Somehow, nfc tools fucked up and wrote a corrupted ndef record.

Phones may have a problem with this because they want to be all fancy and do a lot of reading shit for you, before you even get to do anything else… and this is the problem… if there is a problem that the pre-read process can’t handle you may just get an error message and that’s that… no chance for your app to do anything… is just dead.

This is fixable though. I will have to post an update later today about options.


Have you tried this?

Will it let you write a blank ndef?

Same invalid tag error

You will need an acr122u or probably a proxmark3 to fix this then. Phones are just tripping over the jenky ndef message.

Sorry if it’s been said what phone do you have?

If it is android download and install NFCShell copy and paste the below into the text box and press send. Place over the implant and hold.



He said it was a Samsung Galaxy S20+


So I just tried setting an ntag that I have to the broken ndef as you have shown in the above post (using NFCShell) and it replicates the behaviour I then did what I said and it fixed it :slight_smile:

Fingers crossed for you. @AlmightyJest


Is this the app? It won’t let me open it

Hmm I can’t find it in the app store

Yeah nothing. I still get the error

You may need to try it a few times. May also be a issue with the “default nfc handler” I.e. on some phones you can set the default app to handle nfc card scans.

What happenes when you press ok and scan again?

Same thing, the error pops up, no matter how many times I scan it

OK well I’m sorry I can’t help :frowning: I have tested using a ntag216 with my phone (galaxy s10) and it works fine.

Sorry :disappointed:

That error is coming from some other app that’s reading or intercepting the NDEF record - it’s not the Shell app, or anything except TagInfo. I suspect this might be because there’s two ways of registering to read NFC tags - saying “i want these” to android or forcing a reader mode in a different way. I’d say TagInfo does the second type, taking over read mode.

See if you can work out what app is making that “invalid tag” box. See how it’s popping up OVER the other app?

i would uninstall all nfc apps you installed and start fresh :wink:

1 Like