Please Help! xSIID implant not writing - SOLVED


About a week ago I got the green led SIID chip installed, for the first few days I didn’t do anything I let the swelling go down. Two days ago I download the nfc tools app on my iPhone, and at the beginning the chip was able to write I first wrote a url to a video and that worked. I did it a few more time and that also worked, however by like the fifth or sixth time it stop working and now it doesn’t allow me to do write to it. When I try to write something on nfc tools it tell me the chip is not supported and when I read it it doesn’t say that is writable. When I use tagwriter app it tell me “not NDEF compliant” Am not sure if I lock the chip or if the memory is full. The chip is able to read just not able to write. Please if anyone has any suggestions on how to reset it or make it writable again, i would love to hear them, thank you and I really appreciate it!!

It takes two weeks to get reliable reads and writes. It could be that all the writing caused more swelling and now it’s having trouble.

1 Like

Thank you, I will wait a few days and see if it I still not letting me write to it. Whenever I read the chip this is what it says:

Remember it is easier to get a read than to be able to write.
It needs just slightly better coupling, so if there is inflamation / swelling in the area ( may not be visible ) so I also agree that this is probably the issue

What size was the last NDEF record you saved?
Some Info for you

1 Like

Hey! I got this issue too after a bit with the xSIID. What fixed it for me was to borrow a friends android phone, download the Dangerous Things app, and try the recovery function in it.

Thank you so much, am going to definitely try that! After you did the recovery did you have continued to do a recovery again or did it work good after that?

Thank you for sharing this very helpful information!!

1 Like

Worked fine after, as if it never went wrong in the first place.

Thank you so much for the help, I used an android phone and was able to reset it, I really appreciate the help!!!

1 Like