Problem with xSIID NFC + LED

I installed the xSIID NFC + LED implant more than two years ago.
But today I started having problems reading and writing it. It still works, but I can’t read records and write it.
I am using NFC Tools for ios.
The problems started after trying to overwrite the tag. I got an error “This NFC tag is not supported” in the app.
I can still read the tag with NFC tools, but my old records are not showing up.
I haven’t yet tried other options in the app like erasing the tag or formatting the memory so as not to make it worse.
Is there any way you can help me?

I tried to scan my tag with NFC TagInfo (NXP).
“No NDEF Records”.

I searched the forum a bit and found this thread
And now I have a few questions.

  1. How do I make sure that my problem is related to this thread? Is it likely that I could make my problem worse if I execute it?
  2. If it is related, how can I execute the command suggested in the topic with my iphone? Can I do it with NFC Tools (pro version) or TagWriter?

Can you post the results from the Full Scan tab in Tag Info?

I’m using TagInfo for ios and can’t find this tab in the app.
There are only two buttons in the app: Scan&Launch and Scan&Show. But I think they do the same thing
I can only view the tag details here.
Are there any options to find required information?

iPhone user here as well, I can confirm it’s Android only to get the needed info via Taginfo. I picked up a pixel 3 off ebay for cheap as Android is far more useful for what we do with tags.

1 Like

Just taking a guess here.

What size it the file you are trying to write?
It needs to be smaller than 1k (~888 bytes)

It can be upto 2k but thats a chat for later after you get this issue sorted

I’m trying to create a record with a link. No more than 40 bytes.

I’ll try to find an inexpensive Android smartphone with NFC soon.
But maybe there is a way to get useful data with ios NFC tools? I see a section here called “Advanced NFC commands”. Maybe I can use it to find some useful information?

Yeah, that will allow you to use shell commands

If you think you have exhausted all other options.

@Devilclarke and @NiamhAstra have a post with a “master reset” I can find for you

1 Like

Thanks! I run these commands with NFC tools and now my xSIID is working again.

But now I’m facing another problem.
Incorrect data is being written to the tag or read incorrectly.
For example, I add an entry with URL When I try to read it, I get the entry


I tried to use TagWriter but the result is the same.

Maybe this example is more useful:
I tried to write an URL to my tag.
Source URL was
in the screenshot you can see what I read from the tag after writing.

Show the expert scan of that last screenshot

Unfortunately, this is the expert scan screenshot. This seems to be the most comprehensive data I can get from scanning with iPhone.
I will publish more complete data when I have the opportunity to scan my tag with an Android device.

In the meantime, I found another way around this problem. I increased the size of the written data to 32 bytes by adding a meaningless GET parameter for the target URL. In this case the data was written correctly.

1 Like