Proxmark3 Trouble flashing (POSSIBLY BRICKED)

Been having trouble with my proxmark 3 easy ever since I received it. Keep coming to the same error any way I try to go around it. Anyone have a fix/suggestions to get around this issue?

  1. make sure you have compiled for PM3GENERIC
  2. change the cable
  3. run pm3-flash-bootrom then pm3-flash-fullimage. do not do the flash all command.

Compiled for PM3GENERIC for sure. Even on pm3 bootrom it spits the same error. Will try a different cable now.

is this with the new cable


and you’re plugging into the port on the short edge correct? you’re not using the microusb port next to the button because that’s power only

Indeed using the plug on the very end where the LED’s are.

have you tried using a precompiled version first? download the recommended and run the two flash commands. the “communication failed” makes me think it’s a problem with mingw talking to serial

Will try that now.

Getting same error even when using precompiled build…

Any other fixes?

You can try JTAG or last resort direct write to the chip.