Reprogramming master fob on xAC

Funny you should mention that, After my initial bumbling around to re-find it, I thought the same thing, but I am not sure of the page address to look it up, I looked back in my history to find it and it doesn’t go far enough back.

I also tried the document link I attached above ~“page not archived”.

@Rosco was there much more recently than I was, he may either remember the address or have it in his browser history to search Wayback Machine

Alright, let’s get some detail and answers up in here!

The actual problem I was fixing was an intermittent ground. It was working perfectly fine at the start of the day, then I unscrewed the load output on my battery charger that powers it to add in another pair of wires for a floodlight install (well below rated load, no voltage drop or anything weird)

The annoyance came with the cheap Chinese screw terminals to connect the wires into, they didn’t apply enough clamping force and I didn’t notice at first. Light worked fine (decent size capacitor so I didn’t notice any flicker) and thought I’d retest the garage before closing it. I heard a few random relay clicks from my output relay which was strange, and it didn’t respond to my implant.

I’m not sure if this was the point where I became the master or if it just couldn’t read with unreliable power.

I removed the wires from the power supply, crimped connectors to them, and securely got a small bit of wire into the screws (have I mentioned I hate screw terminals?) - power issues resolved, door lock still didn’t work for me, but worked for my Dad… after I had just tried… we thought maybe it had ‘unlearned’ me through some freak glitch, then I remembered seeing once that someone else had this issue at one point. I grabbed the ‘master’ and tried to program my implant in the usual way and it didn’t work. I then tried the other way around, and the master started operating the relay. I later confirmed this with a spare fob, I was definitely the master at this point.

Probably Yes, but not intentionally

When it happened, no, I grabbed it after I realised what had happened to verify. It is now programmed as a user key. I had heard of one other case on the internet of this happening (can’t find the link now) so I had a good suspicion about what had happened.

Yep, at times, I was tracking down a relay clicking, so was presenting the tag for a few seconds at a time, this is when we narrowed down the ground issue, so it was probably power cycling at this time. Not really sure how long I’m afraid, wouldn’t have been more than 15 seconds at a time I don’t think.

No, I had an intermittent open circuit for a while, but no shorts.

I got some answers! Thanks for taking the time to ask, it all helps in putting the events together into something that hopefully makes sense.

3 Likes

Were these clicks occuring when you attempted to scan or just randomly. (trying to wrap my head around the sequence of events.)

Your Dad’s implant still worked when you first couldn’t get in? Did his stop working when you became master.

Been playing with a spare xAC trying to guess my way in. No joy so far.

1 Like

The relay clicks were random, i suspect a product of the bad ground. Sometimes with a tag the output would ‘drop’ and other times without a tag near. Now that the power is fixed, this isn’t occurring.

His key fob ‘always worked’ but the first time he tried, I had presented mine before him within 5 seconds, so likely would have programmed him in.

All other tags did get deleted though, so the whole device was cleared/reset in some way, we just didn’t notice at first with his since he was with me for the rewiring and touched soon after my attempt failed. It’s unclear at the moment if the change in master tag happened during the ‘bad ground’ or the ‘power restored’ first boot, but my money is on it happening during the intermittent ground

2 Likes

Just tried browning out my xAC. I’ve got it on a variable power supply. Started at 12V, with an active tag propped on the scanner. LED stayed on til 4.3V or so. I tried messing with various combos, but still no luck. Read range was not reduced at all. It might also have still been functioning below 4.3V, but had insufficient voltage for the LED due to the inline resistor.

I found… something.

I have the power supply back at 12V.
There is no tag being read.
The positive is firmly connected.
I’m brushing the frayed end of the negative against the Negative alligator clip very rapidly.

First I noticed that I could occasionally get a flicker from the LED when it should have stayed dark.

Then I managed to stop (connected to negative) when the LED was illuminated. It stayed on, but still no tag.

I tried presenting the enrolled tag, but no difference. After power off, and back on, it works normally. The enrolled tag is NOT master, and no changes are apparent.

1 Like

Interesting, that would explain potentially my random relay clicks, it rebooting rapidly and occasionally turning on the output.

That’s definitely something replicated - now just to figure out how to use that!

Supply voltage off my battery at the time was 13.7V if that helps set some parameters

Well, so far, it makes a nifty night light!

2 Likes

Most reports of master tag reprogramming have been during brown out conditions, scanning a tag, that tag becomes master… and sometimes the first scan after restoration of full power. That’s all I know.

2 Likes

That hardly uncommon in many devices. The trick is, is it predictable enough to be controllable?

1 Like

I’ve got it! video coming up soon, I’ve just reprogrammed my test bench one 6 times in 5 minutes. It’s definitely a dodgy ground issue causing it to reset, then first tag is set as master.

I’ve got a repeatable setup, it’s janky but works. Will share details as soon as I’m at my computer

3 Likes

image

1 Like

I just love good hacking done right.
Well done Sir.

1 Like

Once you see how it’s done, I don’t know if you’d agree its ‘good’ or ‘done right’ - but you will agree it’s done!

Took a little while to do it on the actual reader, but it did work!

There needs to be a load on the power wires of the reader (in my case, a 10k resistor between positive and negative) to make the capacitors discharge quickly and make the power less stable, then connect up the positive and rapidly tapping the negative. Do this while you have an enrolled tag that you want to become the master resting on the antenna. You want the light to be flickering as much as you can (the worst power you can deliver!) with the goal that the light should stop responding when the reader has power (the behaviour you’ll see of a master tag).

Once this happens, it should now be the new master. I imagine you can do this without the tag held to the antenna, but this gives it a good indication of if it worked and makes sure the first one it sees is the one you want as master.

7 Likes

Most excellent. You extended the functionality of the device. This IS hacking done right. Love it!

4 Likes

Thanks everyone for jumping in with ideas, thoughts and suggestions, and a special shout out to those who set up a test bench and experimented alongside me!

This is definitely one of the best forums on the internet, and you people are the reason why!

7 Likes

Hell yeah!

Way to go. I think this might actually be useful too. I’d rather have all my xAC units set to a single master tag. Plus the cardboard disk seems a little janky to me.

Meanwhile…

2 Likes

Really only a little ?

1 Like

Well, I do like the little tin it comes in. :upside_down_face:

2 Likes

I haven’t ‘remastered’ all of mine yet, figured restoring the masters to their former glory was enough excitement for one day.

I thought about grabbing a nice EM4100 key fob or few and do group-masters (The two on the house share a master, the 3 on one car share another, the 3 on another car share another, and the 2 on the last car share one). Then note down the EM IDs and save in a safe place incase they do get misplaced so I can clone me a new master without all the trouble.

Then again, I might not, not sure I can be bothered pulling all the trim panels off the cars when I can just chuck all the masters for any given set into one tin…

If I had known about this before I started this crazy journey, I’d have probably group-mastered them on the bench before installing… Oh well, note for next time.

1 Like