Samsung 3321 not able to register implant

I have a new Samsung 3321 deadbolt lock and I can’t register my implant or any tags that are not Samsung branded!
My implant is an ntag216 chip mifare ultralite. Is there anything obvious I’m missing to get this lock to register the tag? The tag is recognised if I try to unlock, but I can’t register it using the instructions.
The chips I’ve tried to register are a mix of mifare classic and mifare ultralite. So far no joy!


A possibility to try, if you haven’t already???
Do you have a DT field detector, if so have you tried to find the optimal position AND orientation to get a successful read.

Can you confirm it uses ISO 14443A type (13.56Mhz)?


Can you paste us the link to exact make/model that you purchased?

Did you buy it off Amazon?

I ask because I’m very close to pulling the trigger on one of these to work with my NExT.

1 Like

Bought in Australia from biggest hardware store so should definitely be legit. I have tried with a spare implant chip and tags, different orientations etc…no luck at all. The reader recognises them all immediately if I try to use them to unlock the door, it’s not timing out. For some reason the Samsung tags register with no problem, but nothing else will.


I bought this model as it was on the recommended locks that should work. There are also videos of it working. It definitely uses 13.56MHz ISO14443A.
I scanned a Samsung tag using nfctools, and then a spare blank mifare classic tag. Both showed identical info, except uid/serial. I can’t figure out why one works and not the other. Have Samsung updated their code to only work with Samsung tags…that will suck!


Can you scan the included Samsung card with NFC Tools (or another app) and post a screenshot here so we can see some info about it?

1 Like

samsung tag

generic tag

Samsung tag won’t let me read the memory using nfctools.

Went back to shop, tested another identical unit. Exactly the same problem, just won’t register any non Samsung tags. Recognises fine, but no joy getting anything other than Samsung brand tags to work.

It’s possible that specific model of door lock will only accept MIFARE Classic chips. AFAIK none of the implants can act as a stand in for MIFARE Classic. I’m not sure about the lock only accepting Samsung branded tags. You could try an app like TagInfo and do a full scan to get a look at the memory, if you want to know more


There was a specific chip that can act as a MIFARE Classic 1K at one point. It was the xM1+ if I remember correctly, however I cant seem to find it on the site anymore so perhaps it is no longer sold. But I agree, it is possible that this reader can only read and interface with the MIFARE Classic chip and you are SOL.

1 Like

I think the flexM1 is a back burner project ATM. It’s coming though…

1 Like

Ok, that makes sense. Well then I suppose that would be an option when that comes out then.

1 Like

Well that’s annoying, especially after that model of lock has been shown to work with implants. Maybe Samsung have updated their code? I have a mifare classic tag and that isn’t recognised, a card too but no joy. I suspect something hidden in the memory of their tags that is Samsung specific.

1 Like

Most likely. If you wanted to get it to work you would most likely have to crack the MIFARE classic provided by samsung and clone it directly to another MIFARE classic or appropriate stand-in, as they can have some level of encryption, however it has been cracked as I mentioned earlier, though I am uncertain of the details of how to crack them. That would probably be your best bet.

1 Like

Thanks @Jaroot I was hoping for a simple solution where my implant would “just work” … oh well. I suppose I will have to keep typing in the pin entry code if I want to be keyless.
Not tremendously happy with Samsung at the moment.
Big thanks for everyone’s help. Fingers crossed for a solution that will work with implant without the risk of bricking it.

Ok…some digging around…

The code
seems to be the key to all of this. I copied it to a black mifare classic card using mifare classic tool, and success! the Samsung lock recognised AND registered the tag.

Now the tricky part…how to get this to work on an NTAG216 implant?

As far as I am aware it will not work on an NTAG chip, as the MIFARE classic 1k is a different beast all together. However, there is word of a new Classic 1k implant floating around, as there was one previously. For right now you may be SOL tbh.

These are two different types of chips… you have an NTAG216, not a Mifare Ultralight… even though NFC Tools thinks they are the same thing, they are not. NFC Tools is a great app, but pretty stupid in a lot of places.

I also have this lock, and it does work with NTAG216 chips. The trick is positioning your chip correctly to get a read. Also, the registration process requires you use a new “slot” number… though they call it something else… basically when you assign a “position” you need to assign a new empty position number because if there’s already a PIN code or a RFID tag in that position, then you cannot add anything to that position. This is a dumb move by Samsung and you have to manually use some kind of clear command to clear that position before you can add something else there.

What does this mean exactly? How does it “recognize fine”?

Your words are literally an accidental pun… that is KEY A, access bits, and KEY B in the Mifare Classic chip. FFFFFFFFFFFF is key A, which is set to factory default, and the trailing FFFFFFFFFFFFFF is key b, also set to factory default. FF078069 are the access bits for the sector.

This data has nothing to do with anything really… it’s not user data it’s the crypto1 key values and permission settings.

This makes no sense really… did you try the black mifare classic card BEFORE you copied this data to it? Chances are it would have worked just fine because it’s 1) mifare classic, 2) a card with a large antenna… it has nothing to do with the data and everything to do with the large antenna size.

I still think this all comes down to positioning the implant correctly. If you have put it into the common area between the thumb and index finger, then I find the best way to position it is to wrap your hand around the lock barrel, or where the cylinder would typically be, and twist it like a door knob.


Looks like I wasn’t going crazy or didn’t have the knack of correct twisting and alignment. Other people reported inability to register implant ntag216 chips with Samsung. I have tried with a non implanted ntag216 chip with every conceivable orientation…no joy. I suspect Samsung firmware has changed in latest models of lock.