Setting up a new Proxmark3 easy

Hello there !

First this is my second time posting here, and as you will see I’m really (really) not familiar with all of this, so I apologise in advance.

My overall goal is to duplicate mifare cards (see my original post ), and I was advised to order a Proxmark Easy to do that. Unfortunately I wasn’t able to order from Dangerousthings’s shop (mainly because international shipping made it thrice the price, well over the budget I was given), I’m pretty sure my current problem is that it hasn’t the proper firmware installed out of the box and for that reason I failed to complete the starter guide.

So, is there a way for me to manually install the firmware ? I tried digging on github iceman’s page but it seems I’m not getting anywhere.

Hello again,

can you confirm you proxmark is 512MB and not 256MB

What OS are you running?

if its windows. what I would do, is start afresh.
I dont bother chasing my tail and fault finding.

Clean canvas, DELETE proxspace and any any other thing you have done with the proxmark.

once you are ready to go…

try following this guide, where I have filtered out all the information, and just left in the step by step process.

just click

  • Follow each step to the letter
  • DO NOT skip any steps
    Shot cuts lead to long cuts, the set up procedure is not forgiving, anything outside of perfect will result in a FUCK YOU! from the proxmark
  • If you get an error, just STOP, and reply back here with the error and where you are on the process.

I have used this myself a number of times a d zero issues

1 Like

That looks exactly what I was looking for ! I will follow those surgically and report if I step upon difficulties.

Just to confirm, “delete proxspace” means uninstalling (simply deleting ?) the ziped folder Amal advised to put directly onto C:\ right ? And could you please elaborate on what I need to do to “clean canvas” please ?

Correct

Sorry, just my silly wording/ Idiom/ colloquial metaphor
as in starting from scratch…theres another.

Basically, dont have any proxmark or proxspace shit on your computer…

1 Like

Ok, I got all the way until " Plug in your Proxmark3 :pm3_easy: or :pm3_rdv4: We are almost there…"

After hitting the command “./pm3-flash-bootrom” the program gets stuck on “Waiting for Proxmark3 to appear…”. and I can’t do anything but closing it.

I tried unplugging and replugging the device but nothing happened.

[edit]: alright I’m currently using a win7 machine and it seems my problem comes from the computer not recognising the Proxmark3. I tried to manually install the driver included in the “ProxSpace\pm3\proxmark3\driver” folder from the device manager but I didn’t manage to get it done because the device is still not visible.

Try unplugging the USB cable from the proxmark, then hold down the little button on the side (don’t let go). Plug the Proxmark back in again and run the command. Don’t let go of the button until it has flashed.

Also, make sure you are using a good quality cable that allows information flow.

2 Likes

great advice above from @Smellypaddler

and just to expand slightly

.

Test with another USB cable. I also had issues flashing and using the Proxmark until I used another better quality USB cable.

1 Like

TOTALLY worth trying, you won"t be the first to get caught out and won’t be the last

Oups sorry for repeating what was just said above :unamused:. I read the thread too quickly (diagonally, we say in French, not sure if in English too).

Reiterating we say in English :wink:

We actually do use “Read diagonally” but more common is “skimmed”

“Did you read that article?”

“I just skimmed it”

no need, you were being superhelpful…
as usual

1 Like

Where did you purchase your proxmark 3 easy from? Only DT & KSEC offer pre-flashed iceman firmware units as far as i’m aware.

Ooook, so holding the button on the side definitely worked. I think I then got the firmware flashed properly and it seems to work like advised in the guide/video.

Fast forward to now, I managed to scan a card (hf search), identify the encrypted sectors (hf mf chk) and to break them (hf mf autopwn). My problem now is that I can’t copy the data from the previous card to the new one (hf mf cview), I’m getting the error message

“[+] View magic Gen1a MIFARE Classic 1K
[=] .[#] wupC1 error
[!] Can’t get magic card block: 0
[?] Verify your card size, and try again or try another tag position”

And when I try to check the card type it’s confirming that this is a valid ISO 14443-A tag that should be read as a standard Mifare classic 1K. I tried several different badges or and cards, I can’t seem to get any relevant answer from the “hf mf cview” command. I am missing something ?

[edit]: sorry @KaiCastledine I missed your last question: I ordered it from a Chinese seller via Amazon, but I guess it’s irrelevant since I got it flashed with the latest iceman firmware anyway.

Ah sorry, was late to join this.

Holding down the button will allow you to flash the full image. This is a tricky step and easy to miss!

What happens when you run:

hf 14a info

Also, what card are you using to copy it to? Gen1a or Gen2

I get :

[+]  UID: 4A 3A C9 15
[+] ATQA: 00 04
[+]  SAK: 08 [2]
[+] Possible types:
[+]    MIFARE Classic 1K
[=] proprietary non iso14443-4 card found, RATS not supported
[+] Prng detection: weak
[#] Auth error
[?] Hint: try `hf mf` commands
[+]  UID: E6 F8 15 25
[+] ATQA: 00 04
[+]  SAK: 08 [2]
[+] Possible types:
[+]    MIFARE Classic 1K
[=] proprietary non iso14443-4 card found, RATS not supported
[+] Prng detection: weak
[#] Auth error
[?] Hint: try `hf mf` commands

First is the original tag, second is the new one (that I want to copy data into).

did you specifically but mifare classic gen1a uid changeable because if not, the hf mf c-xxxxxxxx commands wont work as they’re for that specific subdivision of chip.

neither of your cards are answering to ATS (answer to select, explains RATS [=]) which could explain why its not showing you its magic capability if it is present.

which I’m inclined to belive its not a magic card which would explain why your cloning isn’t working.

(also fwiw hf mf cview isn’t for cloning the card its for viewing the contents of said card.)

1 Like

As @Equipter says, your secondary card needs to be a “magic” card either Gen1a/Gen2/Gen3. A gen1a card (The most common) will show there but it does not. So either its not a magic card, or it’s a different gen which means you’ll need to use the corresponding commands.

(what i’m about to say can basically be disregard as i’m positive there’s no magic here)

it’s common for magic cards to not reply to the ATS shitty manufacturing has it happen constantly even in non magix

Ah so I guess that’s my problem then, none of my cards seem to answer to ATS. Here are the two models I ordered previously and tried : here and here, but there isn’t any mention of ATS/magic on the order page so I guess I won’t be able to do anything with them.

I looked around trying to find a proper one but how can I tell which one would suit ? I read Jirvin’s post about chips functionalities but there isn’t much details listed beside the RFID and the frequency.