xSIID chip writing, but not saving data?

I inserted my xSIID chip about 2 months ago and have been having a bit of trouble saving data to it. I’ve waited in case it was due to swelling but it is fully healed now, visible under the skin (not too deep), and is reliably lighting up and reading every time I scan.

My problem is I can’t get any dataset to save onto the implant. I will write a new dataset in TagWriter, and then it either does not find the implant, or a couple times it says it successfully saved but if I try reading it, it says the implant is empty.

Any ideas? I’m using my iPhone to do this and don’t really have access to an android to try. If I absolutely need an android I could try to find one.

Are you putting your phone to it mine that or flat?

I’ve tried a lot of different angles, including both showed in the video

Okay update actually. If I scan it a bunch of times, 1 out of every 5ish scans, it will show that there’s data on the tag.

However if I just hold a phone to the implant, it lights up but nothing ever happens on the phone (trying to use the phones reader instead of an app).

That all sounds good

What size is the file you are trying to save?

Less than 1k?

Have you tried just a small text file / url etc?

Have you tried another App?
Like NFC tools, BioCom?