xSIID - NFC+LED read-only

So, I have the NFC-LED xSIID Implant installed.
As it turns out, it comes with its own DS shop link in its Memory. Sadly, I need it empty for my application. Whenever I try to wipe said Memory I get an Error, saying it is read-only (partially). What partially means is that I can swap what is on its memory but i can’t have it blank. I have tried GoToTags for windows, Tag Info for Android and NFC Tools for Android as well.
As it stands now, I have spent quite a bit of money on a chip that I can’t use for what I bought it for. I’m really hoping this issue can be fixed in software, so I don’t have to hav my Implant ripped out again.

Can you tell us more about your application?

What do you want to use it for?

Does it need to be ndef compliant?

You might read this too.

so i have this NFC Lock on my Door - it is managed by the Vians App, if you are familiar. It uses Bluetooth to teach the Lock the UID.
Whenever I try to scan my Implant, my Phone opens whatever is on it, before the Vians App can grab the UID. I have tried it with another regular Tag - it works fine, as long as the Tag is empty.
Sadly, my knowlege of the Software side of this Lock is limited, hence this Forum Post.
I read about the thing with this Memory issue on my Implant. Again it went kinda over my head, I don’t really know how, or if this article can help me.
Kind regards!

You may need to set your Vians app as the default app for NFC? For example, if I scan my NExT on my phone, Home Assistant is going to use it by default. If I scan my Yubikey, the Yubico app is going to open by default.

1 Like

This is a problem with the apps, not the xSIID. None of those apps properly handle the fully NFC compliant memory protection settings we use. We use those settings because we felt it necessary to disable the ability to accidentally lock your tag read-only… however the irony is that these apps don’t parse the lock bits at all, they just look to see if any lock bits are set to 1 instead of 0 and declare the tag is “read only” when it is not at all.

Use the Dangerous Things Support Tool or NFC Shell to blank your tag.

Using NFC Shell you would enter the commands;

A2 04 00 00 00 00
A2 05 00 00 00 00
A2 06 00 00 00 00
A2 07 00 00 00 00
A2 08 00 00 00 00
A2 09 00 00 00 00
A2 0A 00 00 00 00
A2 0B 00 00 00 00
A2 0C 00 00 00 00
A2 0D 00 00 00 00

This will overwrite the first several pages with null bytes and effectively completely blank your tag so not even an empty NDEF record exists.