Flipper RGB Mod :flipperzero_white:

Nothing will light up until you go to the RGB settings, and you can’t do that until your SD card reads.

Can you remove all your work, and clean up the solder on the pads and see if the SD card reads again?

2 Likes

Yup, I ordered three a week or so ago. Which one is the 3v3? The little one above the vibro pad?

I’ll undo all my wires to see if I get the SD card working again… Thanks everyone!

I’d keep all your wires. It’s likely you nudged a resistor or capacitor. Check the board around your solder joints to make sure nothing is nudged or your sd card isn’t in upside down

The extra wire should be ran like this

Right post to the pad above vibro

2 Likes

Well, I undid the wires to see if my SD card would work again and it didn’t. I can’t tell if I nudged any of the surface mount caps/resistors. (I’m going to need some magnifying glasses. This is making me feel my age, and it’s no fun…) I tried using my phone for close up photos. I don’t see anything out of the ordinary…

You bought 3 Flippers?
If so, can you test your sd card in another?

This looks like some heat damage from the soldering iron

image

But it doesn’t look deep enough to cause any issues.

Nothing else looks obvious to me

I wonder if, during your soldering you held the heat to the solder pads a little to long and over heated a component :man_shrugging:

2 Likes

Oh, no no. I just bought this one flipper this month. I ordered 3 rgb mods. I did test the SD card in a computer and I can see all the files.
I probably did over heat something :frowning:, or got solder somewhere it shouldn’t be. I used an old radio shack desoldering tool and might have gotten “splash” when using the squeeze bulb.

I’ll see if a guy in town with better tools can revive it. He does video game console mods and I think he worked on a flipper once too. I thought I could do it myself, sigh…

2 Likes

If I have time I’ll compare your pictures to my board to see if anything looks out of place

2 Likes

Respect, but maybe starting with one RGB mod at a time is wise (been there, fried that!). Glad to hear the SD card seems good after testing it on your PC.

Sounds like overheating or some rogue solder might be the gremlins in your machine. Desoldering tools can be finicky, that “splash” you mentioned could be the culprit

1 Like

I’ve never seen this happen with a soldiering iron. Some LEDs and BGAs can popcorn if you’re not careful when using hot air but that’s a different story…

These things can often take a lot more heat than you think.

1 Like

I have 100% lifted some pads and destroyed some boards because i kept that heat on too long.

The first keyboard i built i ruined the board because i didnt know how long to leave the heat on and liften like 3 pads.

1 Like

Alright i compared your picture to the flipper datasheet. None of the components for the SD card are even near where you have soldered and shouldnt have had any issues even with spatter.

Unless there is damage on the oppsite side there are two capacitors below the directional buttons that are related to the SD card that i cannot see.

C60 and C61 are located below the bottom arrow directional button and to the right. I dont think you could have hurt either of these but its worth you visually checking them. The remaining components all surround the SD card itself.


SD card components are

  • R20
  • R21
  • R22
  • R23
  • R24
  • R26
  • R28
  • R31
  • R65 Unpopulated
  • R66 Unpopulated
  • R67 Unpopulated
  • R68
  • VD5
  • VD6
  • VD7
  • VD8
  • VD9
  • VD10

2 things.

  1. When you dismantled the Flipper, did you remove the sdcard or did you kind of pry the main board out? If you pried it up without removing you may have bent some of the pins on the SD Card carrier or broken the traces.

  2. Has this SD card worked in the flipper before? Do you have other SD cards you can format and try with the flipper? I know it works in your computer however the flipper and computers use different protocols to access SD card data. You have to make sure the card is formatted to Fat32 and see if flipper can read or write data to the new card.

From the images i dont see any issues, so those are the only things i would check.

Oh, and of course, please check the SD card slot doesnt have debris in it.

2 Likes

Good spottin’ Tex.

Since the SD card is still in the SD card caddy whilst the Flipper is dismantled, and as its an easy thing to forget to do, that could be a real possibility.

Of course, it could have been re-inserted to test functionality after the mods…

Whatever the cause of the issue, I hope its an easy / cheap fix.

Have you tried this yet.

2 Likes

Awesome! I’ll poke around and see what I can see. Thanks for looking at the schematics too, I wouldn’t have been about to make heads or tails of it.

1 Like

When I dismantled the ‘FZ’, I made sure to remove the sd card beforehand. It was only after I applied power to it that I remembered to reinsert it. It was the same card I was using before the ‘mod fiasco’. I am able to get to the “format sd card” menu and tried that, but it says card not found. I’ll find a magnifying glass and poke around inside the slot to see if anything is lodged in there or weird looking. I really appreciate the time you’ve all poured into helping! You really are the best community!

1 Like