I think I fried my XAC

Okay I’m a little confused on the operation of the xac and how I’m supposed to wire stuff.
Correct me if I’m wrong in these assumptions

  1. “NC” means normally closed
  2. “NO” means normally open
  3. “COM” is just the other side of that normally closed normally open circuit, i.e. if there was 12v connected to “COM” and “NO” then when you scan your tag you’ll read 12v on the NO wire?

Now here’s where I’m confused, what is the S3 jumper used for? I had switched it to the 12v high in troubleshooting the XAC connected to my car door lock and I got a bunch of smoke off the board. .Before doing so it worked on a test bench, with an adjustable dc power supply and a test light to see if I knew how to wire everything without frying it right away.everything worked as expected.

In the car I found a 12v constant and a ground, the XAC will run on it’s own door closed car locked for 20min(my car waits to turn a lot of things off acc power sometimes, terrible if you have an old battery;you have to replace it as soon as it gets old or it’ll die all the time. power mitigation in the works, just trying to get it to work right now)

The issue comes when I’m trying to wire the relay to my door lock. I’m not 100% how the switch works, as there’s only 2 wires but it works both ways(I assume to lock the door it just reverses polarity?), but for my purposes it’s fine because I can just jump the 2 wires and it’ll unlock the doors. So I wired the com and NO wires to it, scanned my implant annnd nothing. Tried flipping them, nothing. Jumped the pins with a wire, unlocks the doors.

At a loss I tried switching the S3 jumper from gnd low to 12v high and the jumper started getting red hot, and the board smoked. It seems just the NO side of things got fried, and everything else was untouched. NC still works, and the RFID functions perfect still. NO(or COM,it was the white wire, it was late at this point so I can’t remember) now seems shorted to ground and will unlock the doors as soon as I connect it to the wire that needs jumped on my door lock switch, whether theres supposed to be access or not.

So I suppose my question is to start what the heck does S3 do? And why didn’t wiring com and NO to both wires of the door lock(the ones that I can jump the pins to and it unlocks) unlock the door when I scanned my implant, the XAC is just closing that circuit between NO and COM right?

The S3 jumper allows you to connect the COM terminal of the relay to either the +12V supply or ground. But that 12V pin goes though a diode first so chances are that you fried that part of the board. You can still solder a regular diode like a 1N4001 between the +12V pin of the wiring connector and the +12V pin of S3 and that should fix it.

1 Like

I see thanks much!

What would no jumper passive output mean?

What is the XAC?

X Acess Controller

Usually the v2 is what you see these days
It’s a small pcb with an antenna that works as a relay with 1 or 5 second timings for either normal open or normal closed

It’s pretty bare bones, but it’s an easy enough thing to wire into an existing thing to function like a rfid switch

I’ve used 2 to let me open and close various gun safes

They are LF EM mode only, but have a pretty decent read range


If you remove the jumper, the three relay terminals (NC, COM, and NO) will be isolated from the rest of the wiring.

In fact, the range of the xACv2 is amazing, I recently bought the updated version of the Uhppote reader and ended up disappointed.

Did you see the YouTube videos on the xEM xAC v2?
They should also help with your understanding




I did. I must’ve missed something, I think I’m at that awkward stage of “I think I understand how relays work” and actually understanding them in practice. In all fairness, I did have everything working as desired with a test bulb. With the jumper removed, the relay will just act as a “wire” so to speak, just connecting COM to NO?

true; // That’s exactly what it does. A relay is just an electrically controlled switch.

Here’s a good explanation of how they work:

Those most experienced Electrical Engineers in the world still occasionally release the magic smoke. Honestly, if you never do it, you weren’t trying very hard.

So… Good Job! :laughing:


I once released it in my face for that matter… I had two electrolytic capacitors of the same size on my desk but different ratings and as you might guess, I used the wrong one while assembling a prototype. As I powered the thing up, it started buzzing so I leaned over the board wondering what was going on… And that little power supply capacitor blew up on my face leaving me utterly confused. Until I powered everything off and looked at the board.

I was trying so so hard not to too haha. Even went to the local maker space to use the dc power supply before hand. Whenever I do make magic smoke I always think back to mythbusters and how often Adam and Grant blew up electronics. makes me feel a little better knowing they did it too haha. Well I’ll have more time tomorrow afternoon to work on it. @enginerd if i operate without the jumper, will I still need to replace the diode? Or if I use the gnd side of the jumper. I don’t think I need 12v high for my purposes

I’m assuming that you fried the diode that’s on the xACv2. If you did, the board will not power on until you replace it or bodge another one between the pins that I mentioned.

I’m hoping that I diagnosed things correctly but would still like to know if your xAC powers up?

Here’s an illustration of where the diode needs to go:

@enginerd is politely showing the diagram from when I burned out my XAC on my second safe project

There’s no big shame in it… I was able to fix mine, and even if you can’t they are pretty cheap and relays are weird… add in jumpers and stuff and it’s a miracle I didn’t break my first one

1 Like

The XAC operates as intended on the NC side of things, still registers my implant, and will open the circuit when scanned. Technically, in this state, I can “unlock” the door with the XAC by opening the NC circuit by scanning my implant, then as soon as my implant is removed(in 1 sec delay) it will trigger an unlock, but that means the internal door lock buttons don’t work because it thinks the unlock button is being held down. It also for some reason doesn’t work with the doors locked, the XAC still beeps but it doesn’t unlock the doors like it does when the doors are unlocked.

Hard to explain. But the main point is the XAC still works, just as far as I can tell only on the NC side. The NO side seems to be permanently NC now. It’s in my car right now working in jank “unlock” mode. Kinda also wanted to see if it would kill my battery overnight before I take it all apart again for more testing. I should have more information for you tomorrow night

You could do some calcs
The xAC V2= 60mA Idle

Do you have some sort of battery protection like a Low Voltage Cut Out?
You should be fine overnight, but if that is something long term you are considering, or put a Momentary on inline with your 12V power, so It only draws when powered

100mA Operating if you were wondering