Installation issue. Stuck here


Sorry, it’s in french but the message is " Device USB\VID_9AC4&PID_4B8F\iceman needs install to go on"
Nothing happens when I run the flash commands
Thank you for helping

I can’t see your commands before the ones you shared in your screenshot

Can you confirm you did the following?

git pull

make -j

rather than the make -j, you could have seen in what ever guide you are following, make clean && make all, but make -j is the reccomended command by iceman

if those work for you

then continue on where you where

  • ./pm3-flash-bootrom
  • ./pm3-flash-fullimage
  • pm3
  • hw tune

Thanks for answering, I followed step by step the instructions from here
so I used make clean && make -j8 all

hw tune

return no error, but won’ do anything either.
I’ll try what you suggest.

Btw I am using the latest release 3.11 and all the tutos are using 3.10
Should I try the previous version ?

That is so strange… it should be saying something even if you have no proxmark connected. Where is your proxspace at on your drive?

C:/ProxSpace as recommended
My unit is recognized by Windows as COM11
I also disabled my AV, just in case

In fact if the PM3 is disconnected I get something

That is so strange… so it says waiting for proxmark to appear and how long does it wait? Or does it just move on immediately?

I believe it just waits till I hot plug it, then the command is executed, but nothing happens.

Confirmed, looks like it can wait forever

hmm interesting… is this proxmark purchased from DT?

oh also confirm your device manager screen that shows the ports in your system… post a screenshot of that?

ok i think we can forgo the screens… basically at this point let’s try this;

  • hold the button down on your proxmark3 and keep it held down
  • plug it in to USB port
  • while still holding the button, confirm the PM3 is visible in device manager. it may have a different com port but that’s ok… take note of the COM port number.
  • in proxspace env, at ~/proxmark3 prompt, run pm3-flash-all
  • wait until it’s finished updating
  • release button, wait 5 seconds
  • unplug from USB, wait 5 seconds
  • plug in to USB (no button)
  • run pm3 to start client
1 Like

Weird, pm3 appears in panel (com11)
But when I run pm3-flash-all while holding button I get the same message (Waiting PM3 to appear)
When I release the button the button I get the prompt but nothing happened

And yes, it is a genuine Iceman Proxmark3 Easy


ok … do you want to do a google meet call? i can DM you a link… or actually anyone who wants to join ahah

I’m there now … at least while i can be… today is kind of random and crazy. my goal is to see the LEDs on the camera and try to determine what’s going on here

ok… let’s just confirm we can get a COM port to show up when holding the button… that’s the first hurdle. You have to hold the button down and then plug in the USB cable and keep holding the button… does a COM port show in device manager while plugged in and holding the button? If yes, what COM port number? Still 11?

Sorry I was out, walking the dog.
I’m french and while I can manage write/read in english, talking might be more complicated for me.
Anyway thank you for the offer.
For now I will retry the process you described, and I will leave it for today.

Yes, always com11

Ok… so when you are holding the button and COM 11 is on device manager, what do the LEDs on the proxmark3 look like?

red and green on blinking, then off
After deplug/replug, red and green are on again then off

hmm… that’s not good. Ok… let’s try something else…

Hold the button, plug the USB cable in, but then after only 1 second, let go of the button. What do the LEDs do? Do you still see COM 11 show up?