Proxmark3 Easy Flash Issues

Sorry Everyone, I know I have been posting a lot, just trying to get situated with everything. So I have a PM3 Easy that I just purchased. Trying to flash it with Iceman Fork of the firmware. Proxspace loads and it gets to “Waiting for Proxmark3 to appear”. As you can see in the screenshot when I run ls /dev/ before and after plugging it in, it shows up and is detected by Proxspace but it is still not being detected for flashing. I have poked around some threads but did not see my exact issue yet.


1 Like

Hold the button before you plug it in and keep it held until the flashing is complete.


So I tried that and I get no different response. Windows also sees the PM3 and is identifying it as Proxmark 3 so I know the drivers are loaded. It is weird. More so probably just a lack of knowledge on my part.

1 Like

OK, reading through this in detail, you have pretty much everything wrong.

First, windows uses COM ports, not /dev path. So it’s needs a COM port in the command.

Second, if it’s not flashed, pm3 will never detect it anyway. Why are you running pm3 when you need to flash it?

Lastly, the button holding thing is still required for the easy.

I had lots of issues with communication on Windows, using the precompiles was by far the easiest

PM3 Easy - Easy Windows 10 Firmware Flashing Guide


So we are running Proxspace on Windows. Windows passes the device through to Proxspace. Proxspace can see it connect and disconnect, though it is just not seeing the PM3 as a flashable device. Even when using the PM3-flash-all and PM3 <Port#(ttys4)>. Do I need to flash an official firmware before flashing the Iceman Fork? I assumed it came with the oem firmware and would be overwritten so I did not bother flashing any OEM firmwares, only the Iceman.

1 Like

Again, tty devices are not used in Windows. You have to use COM8 or whatever. You don’t have to flash the official firmware, but the Iceman pm3 software will not communicate with a device that has factory firmware on it. You have to flash iceman first.

From what I can tell you are trying use the proxmark on Windows and using WSL (Windows Subsystem for Linux). This is how I also mainly use my proxmark also.

You still need to install the drivers in Device Manager then it should be detected in WSL. I have had to uninstall the drivers/device completely in device manager before and reinstall the drivers.

Since you have a PM3 Easy, you need to specify before compiling the firmware that its for the Easy. By default its expecting an RDV4 and could cause problems later.

Did you ever get the PM3 Easy working (be it on stock or Iceman fork)?
Are you in the DT Discord? I would be able to provide some more instant feedback and guidance

1 Like

Currently we are using Proxspace which I think is different. I am just following a forum post I had seen a while back for the config. Is WSL the preferred way?

I personally prefer WSL since its Linux based and I have some Linux knowledge. I feel like it also removes any of the common issues with running a proxmark on Windows.

1 Like

I use a pm3 easy and i use it under windows natively no wsl or anything is there a reason ylur not doing that?

1 Like

I originally tried it under native Windows and had nothing but headaches. I eventually got it working but would also run into more issues as I tried to do more.
Decided to give WSL a shot since I already have it installed and use it for other things. Got everything setup and it worked 1st try. Since then Ive had minor errors and easily corrected them.

I also personally prefer Linux over Windows.

1 Like

I only went this route because I was using THIS guide which was outlined in THIS DT post.

I am open to any other methods by all means lol.

Still wondering why you haven’t just specified a COM port yet.

The guide you linked is the official guide for the Iceman fork, which I have used several times. It does have install/compilation instructions for WSL further down.
Its up to yourself what you’re happy to use for the proxmark for the foreseeable future. Didnt mean to muddy the waters with mentioning WSL.

Still wondering why you haven’t just specified a COM port yet.

If they are using WSL then COM ports wont work since the ports are translated into ttySx.
If they are using Proxspace then a COM port should be specified.
From the screenshot in the original post it looks like WSL thus specifying a COM port wouldn’t work.

1 Like

He specifically said he’s in proxspace though, which is why ttysX isn’t working.

Yes, but if they are trying to use Proxspace via WSL then a specifying a COM port still wont work. Even since they can see /dev and ttySx ports suggests they are using WSL.

If they were to use Proxspace on a Windows shell, then a COM port should be specified but this doesn’t look to be the case.

1 Like

Try the easy flashing guide I posted above, I had a lot of issues with ProxSpace communicating with the PM3E. This method is a simple unzip and batch file.

One other question - which USB port do you have it plugged into? A few folks have accidentally plugged it in the side port, but you’ll wanna use the bottom port.

1 Like

I have, also as mentioned in one of my earlier posts I even tried the PM3-FLASH-ALL which should attempt to do any device on any COM if I am reading what that command does correctly.


1 Like

I will try the easy guide and see if I have any luck. If not maybe I can get in the discord this afternoon or over the weekend with @Jirvin and whoever else wants to help out and see if we can get it squared away. I appreciate everyone helping out so far.