Flipper Bluetooth ALMOST Connects

I’ve looked here and on Reddit, but I haven’t seen this exact problem, so I’m making a new post.
I just got my Flipper yesterday. I grabbed a 32GB SD Card, and I updated the firmware through my laptop. All looked well. Then I installed the app on my Pixel 8 and tried to connect Bluetooth.
I turned Bluetooth on on the Flipper and went to connect through the app. It searches, then I get a prompt from Android asking whether to Pair & Connect or cancel. I tap Pair & Connect, and then I get a prompt asking whether Flipper should have access to my contacts and calls. I check the box and tap Pair.
For less than 1 second, the Flipper displays a Pair Code, but the phone never asks for it. Flipper goes immediately back to the Bluetooth menu and the phone says “Unable to connect Flipper. Connection was cancelled or the pairing code was entered incorrectly. Retry or Cancel”
I’ve rebooted both devices. I’ve tried pairing directly from Android instead of the App, and I’ve uninstalled and re-installed the App.
Any suggestions would be most welcome!
Thank you!

1 Like

odd problem! I would not bother trying to connect through the app… restart the phone and go to the android bluetooth interface and pair directly with the flipper before opening the app. try to complete pairing that way.

why this? don’t share … it complicates the bluetooth handshake.


OMG, you are magic. THANK YOU! This worked. I swear I had tried connecting directly through the Android Bluetooth interface, but maybe I hadn’t done it first after restarting.

Thank you!


You even wrote about it here

So its odd that it worked the second+ time.

Now that you have connected, have you tried going through the App directly?
It should just connect automagically and start syncing.
Also a little gotcha, Bluetooth on Androidrequires Location services to be on for a bullshit reason, but if its not on, Bluetooth MAY NOT connect.
(not sure about iPhone)
Alternatively you can connect via a USB cable.

What Firmware are you going for?

There are a few frequent users of Flipper Zero here, so feel free to ask if you need some help


Yup. I guess I didn’t do that on a fresh restart with the app closed.

Yes, things are working correctly now in the App now that we be paired.

I installed the main release firmware. I’m new to this space, so I wanted to see the release before messing around with anything experimental.

I’m honestly not sure what I will use the Flipper for other than LF reading and writing. A friend of mine who has one told me about the recent ban in Canada and that our own US government is looking to follow suit, so I decided to get one while I still could.

1 Like

Nothing wrong with that.
Experimenting is good
The factory firmware is good.

Personally I have tried all the “Main” firmware alternatives (unleashed, xtreme, roguemaster)
There is not right or wrong choice.
I personally prefer Xtreme, but they are all good options.

here’s a “how to update” I wrote up
(you should be able to follow it step by step, please let me know if you get stuck so I can help you and fix the guide if required)


When you’re ready and willign to possibly fuck it up, let me know as i have the RGB PCB’s. its a straight forward install but requires soldering and desoldering which can be intimidating.

I personally love the Unleashed firmware. but anything other than stock is best. Not to mention i can emulate every amiibo now :slight_smile:


@Hamspiced @Pilgrimsmaster
Thank you both so much! I’ll keep playing with things and learning!

Well, I just tried emulating my garage door opener, and found that it’s transmitting at 390MHz. Flipper so pleasantly reports that that frequency is not legal for civilian use in the US.

What are you both using Flipper for, if I may ask, and what drives those FW preferences?

Well if you REALLY want to, there are ways my friend…

I think unleashed may have been the first to unlock regional restrictions

Pretty much Implant things
The LF and HF antenna work really well with implants, as in surprisingly well.

It is awesome for any LF stuff, read, write, emulate

HF I use it for Mifare Classic gen1a stuff, and other reading and emulating.

I wrote this “Mifare how to”

Before following this one, read through it first. There is a shortcut that becomes apparent toward the end.

I occasionally use it for it’s other functionalities, YouTube will give you heaps of examples ( Take some with a pinch of salt, they are misleading unless you know how the tech works )

I actually liked all the non-stock Firmwares, and early on some had better things over others.
eg. Unleased with the regional SubGHz restrictions removed.
Now, most have the same stuff, but what sold me on xTreme was the clean install, all the non polished apps were removed, so the apps you had on your flipper, you knew would work.
The GUI was an improvement over the others.
The updates were frequent enough for me, some were more frequent, but not necessarily an improvement, so I found xTreme to be more reliable.

Some people mentioned xTreme crashing, however I never saw that.

The “Flipper Thread” is over 700 posts, but worth a read if you have the time to play catch up

My best advice is, try them all, its pretty simple to do and once you do it the first time, you’ll see how easy it actually is.

In fairness, I haven’t tried the others for a while, they may be “better”…

1 Like

I use my flipper primarily to write to my Xmagic when i am traveling.

I use it to read my offbrand Xbt. Which i build my firmware from source to include the correct offset.

finally i use it on my Nintendo switch. I uploaded ALL of the Amiibo files to it so i can get all the cool little amiibo perks on the games i play (Zelda, Metroid, etc).

I used to use it to mess with my wife and spam the apple commands, but i havent done that in a bit. I also made a few different dev and wifi boards for it but it became too cumbersome to do but i sell the RGB boards now that i have a streamlined process for it. Im currently the only seller on amazon for these at the moment.

I switched from stock to unleashed because the community is lightning fast with updates. it was one of the first things i did was get off of stock firmware and only run unleashed. opens up a lot of different oppertunities for the device and the updates come faster than stock. for instance there were changes that members here made to the FDX-B code that allowed for Imperial units to be displayed instead of Metric. I submitted this to the Unleshed repo and it was implemented in days to be part of the global unit conversion. Xtreme came about a week after that, and then stock came about 2 weeks after xtreme.

I had issues early on with Xtreme. It would go into a deep sleep state and not return. or it would randomly crash and id get the angry crashed dolphin screen. Had a few issues with it flashing the multi-boards i would make, it would crash mid flash and id have to use Tastmonizer to reflash the ESP32 via serial. made it painful.


Things are being done:

Thank you, @Pilgrimsmaster


What do you mean by “off brand” XBT? Is someone else selling these things?

I have an fdx-b chip that reports temperature made by destron fearing but not supplied through DT.


Cool, thanks for the info.