Glowforge is a great piece of machinery, however

… it’s not going to work for our purposes

The primary reason I looked into getting a Glowforge over another CO2 laser system was the bed camera and layout tool. Pretty much every CO2 laser system I’ve seen is a C&C laser head and some basic software. You place your target material on the bed and align your job file over the target material based on a pixel to distance ratio. For every pixel to the right or down from the upper left corner (0,0) means move the laser head N millimeters… so if you have a ratio of 1px per 0.1mm and we put a square on the canvas such that the top left corner of the square sits at 50,100 (50 pixels down, and 100 to the right) then the laser head will move to 5mm down and 10mm to the right of the top left corner (0,0) and start firing the laser.

This works great for cutout and etching projects where you just toss a big ol’ hunk of whatever in there and blast it… exactly where the pattern sits on the material isn’t paramount, you’ll have typically have a huge margin of waste material all around your target pattern… so who cares.

This kind of set up is also great for jig projects where you create a design, position it how you need it, and blast away… then the next time for the next run it will do exactly that same pattern… so if you always have your target material firmly seated at 0,0 on the print bed you will always get the same laser pattern every time. This allows you to etch or cut out holes to make a jig in one piece of material, then you can place your real target material or object on to or into the jig, then run your real pattern and always hit the intended target exactly where and how you mean to.

The problem is, when I am making things I am using a process that does not lend itself to precise layouts. That means the target objects I need to cut or etch are going to be randomly positioned and aligned within my source material. That is why I wanted to work with the Glowforge… so I could presumably use the camera system to view the print bed and my targets, then drag and align my cut patters over the targets embedded in the source material to a degree of accuracy that a salesperson I spoke to on the phone within Glowforge sales department assured me it could accommodate.

An offset problem

The reality is sort of a mix. The camera system is good enough that I can zoom in and place my designs around the targets with the required accuracy. However, there is an offset problem. The camera system in the Glowforge is a single fisheye camera mounted in the lid, positioned dead center over the print bed. That means to present a flat representation of the bed in the design tool, there are some algorithms being employed to flatten that image out. Unfortunately I think there are two problems… first is that the algo probably isn’t perfect and has a % margin of error which only grows the further out from dead center you get, and it’s also likely that there are physical issues with the camera being mounted to the lid which has a large hinge it moves on and very likely some horizontal play sliding along that hinge which would throw things way off when attempting to position something to within 0.1mm accuracy. So how does that play out when we actually attempt to laser something based on the camera? Let’s take a look.

Camera calibration

After some failed attempts with real material, Glowforge support (who have been excellent btw) instructed me to run through a beta calibration procedure (they also use Discourse!) which etches out a pattern of Glowforge logos on a piece of high contrast new material. Then the system attempts to calibrate the camera based on this pattern.

Testing calibration

After doing such a procedure I hoped it would be “problem solved”, but alas no the same issue persisted.

Positioning the pattern over the target
I simply placed a pattern over one of the logos and proceeded to print.

As you can see, it did not turn out well…

Some hope

There may be some hope yet for Glowforge though. You can see as the print process started, the bed camera image jumped over. It jumped over quite a lot, actually placing the pattern such that the laser would be cutting right through the right side of the logo.

After the print, the bed camera jumped back to the right slightly, showing the actual print aligned with the pattern just on the edge of the logo. I have no idea if this is some kind of image automated image alignment with the score marking on the target, or if deep inside the bed camera system there remains some bugs to be quashed. If it’s the latter, then it appears that camera accuracy is possible… but that accuracy is not being represented throughout each step of the design process from layout to print to post-print.

Returning the Glowforge

In the end, I can’t wait for these bugs to be sorted out. I am returning the Glowforge and will be exploring other options.


eh personally im neither here nor there about the titan engravings, its not vital to its processes as a magnet I’m just impressed with the effort you’ve gone through for it


Totally understand. If it comes down to it and I’ve not sorted out markings by the time testing is completed, I will offer immediate shipping sans marking to those who want it sooner, without any marks.

Thanks. It’s really for you guys. There are some who have expressed a deep desire to have specific markings, which I understand. I’m applying my best possible effort to make that happen as promised :slight_smile:


Would i like marking yes is it nessicary no. Do I love you for pushing yourself for us yes but I also don’t want you to burn yourself out.

I love these updates and info on the project as it continues.


I’m not a titan backer, but I totally agree.
Whenever I back something, I always appreciate the updates, no matter how small. You don’t want any significant amount of time dedicated to updates that takes the “makers” away from production, but just enough to be “kept in the loop” , timelines are great, but delays I feel are one of the most important things to be informed about, these things happen, but tell us why, what’s being done and a revised eta.
A few simple words, and it would stop backers asking sooo many and repeated questions.
A lot of Indiegogo and Kickstarter campaigners could learn a lot from Amals approach.

Good on ya’ Amal :+1:


Way to go to turn a big bump into an educational endeavour! :grin:

1 Like

Is the machine consistently off-target (in other words, is the error repeatable)? If it is, you could apply some offsets. Or print only a few items on the zones that are least affected by the error (over the center of the fisheye lens presumably, where the interpolation is minimal).

If it’s not repeatable, here’s a technique I use myself: put your target close to a sacrificial target. Print some simple geometric shape on the sacrificial target. Optical-recognition-detect the shape of the final target and the geometric shape, determine offset. Rinse, repeat. It’s twice as slow but it autocorrects itself at each pass.

Provided your laser etcher is controllable programmatically of course.

It’s repeatable it seems but it’s algo is off by a percentage not a flat offset. Each mm closer to dead center has a different offset. Also the software is cloud based only so no option to customize.

1 Like

Yeah that’s what fisheyes do. I was more thinking of an offset table for different locations. Kind of an OCD thing to calibrate though, but at least you get each predefined location lined up perfectly.

Well color me surprised. I’m shocked. SHOCKED I tell you!


Do you have the ability to change steps per mm for the drivers?

Its not a linear relationship unfortunately :frowning:

Before you return it, would you just wanna blast mine to make them anodized? If it is “more” biocompatible and you don’t need a design, would it be possible?

No worries either way.

Posting a follow-up here about the Glowforge.

I mentioned before that the Glowforge support people were excellent, even if you aren’t paying for the pro version of the design tool. They sorted me out on the camera calibration issue. The calibration process completed successfully in my earlier attempt however the correct procedure afterward is to lay down your design and then run through a “set focus” process before each print. This will get the real world height of your material and put the finishing touches on your work bed camera image.

Ultimately though, problems still persist… just different ones. Regardless, here is my second attempt at etching around a fiducial from the calibration process.

The design is laid down over the marking…

The “Set Focus” process is used and the print head (which does indeed have a high def camera inside it) is positioned over the focal point and takes some measurements. The camera image shifts ever so slightly a pixel or two so I carefully reposition it, then hit the print button…

The print job fires… though I’m not sure why it’s faster and a lighter score than my previous attempt… the material selection and settings are identical… but whatever… we’re not here for that right now…

As you can see the alignment and the actual print is much much better…

Marking a Titan

But now the real challenge… can we target a 4.5mm diameter Titan and keep the accuracy? At first I tried the DT logo… but you can see there are issues with the lines and the SVG that I used apparently had some raster data in it because after shrinking it down it looks like dogshit… but still I pressed on. Here we see the set focus process starting…

Now we can see the image has slightly shifted… but it’s still well within the bounds of the Titan so it’s perfection is not enough to worry about for this test…

I won’t bother with detailing the results of this test… but it’s slightly off the edge of the Titan… so I follow it up immediately with a simple circle mark…

The print is ready and the mark does not appear to have moved at all… so here we go…


Just as a side note, the design tool has 3 “types” of actions you can do with the laser… Engrave, Cut, or Score…


The type of thing you’re doing seems to have a multiplier affect on the speed and and power settings for the laser. For example, if you’re in the Cut menu, a “speed” setting of 800 does not appear to be the same physical speed as a speed setting of 800 in the Engrave menu… even though they both say 800. Nowhere is there any mention of “mm per second”, for example… not in the tool and not in the documentation. I think this is meant to be a helpful kind of “dummy gauge” and the tool is trying to do more for you (probably more than it should IMO).

More importantly, the 3 different options offer different features… for example, I uploaded a solid circle SVG and under the engrave menu I can see “lines per cm” to basically select a resolution setting, and when you blast your target you get the solid circle (more or less… more about that later)… but if you are on the cut or score menu, that same solid circle just does the perimeter of the circle… it “helps” you by just scoring or cutting the circle out, not considering the entire filled in circle to be a laser target… only the perimeter. Presumably this would be helpful for the target market of maker moms and trinket businesses who need to be able to slap a photo or picture of something down quickly and just hit PRINT and it does the rest… and for that I can see this feature being very useful… but without an “advanced mode” where I can just set actual speeds like mm/sec and laser output power in terms of % of watts (the laser is 40W, and I want like 80% power)… without that, it makes things hard for technical people wanting to do very precise things.

Back to the Titan

Ok, so I hit print… but it’s basically not printing… it’s barely engaging the laser…

I’m not really sure what’s happening here…


The settings would seem to indicate that the laser should be moving quickly at 75% of whatever it’s 100% power level is for engraving… but it should at least be consistent.

The normal “lines per cm” setting is 90… but I figured since I wanted a perfect circle I would bump it up to the maximum 535… maybe that is making it choke? No idea… so let’s try the default 90.

I assumed that since I had changed nothing that if I just hit print it would use the previous print settings including the focus setting but no… I hit print and the print head wanted to do an autofocus… so no… cancel that… run through set focus again… and then print. Note to self… you must use “set focus” every. single. time. The only problem with running set focus every time on such a small target is that it appears to be finicky… this time the reticle around the target shifted and so did the Titan image (the circle graphic shifted slightly)…

This really shouldn’t happen since absolutely nothing has changed… but onward…

Well setting it to 90 wasn’t the answer because it printed for even less time with even less laser engagement. This is a solid circle… it should just be blasting the hell out of the surface in solid lines as it passes over the Titan… but it’s barely tickling it.

With regard to laser power, I’m not sure what the difference is between 100 and “full power”, but it probably has something to do with that multiplier based on what it is you’re doing (cut vs engrave vs score)… but I figured I’d try full power and see if we can get the laser to remain engaged over the target area.


Well there was a bit more energy from the laser that time… but again it did not remain engaged over the target… there were fits and spurts but no solid discernible periods where the laser remained engaged while passing over the Titan.

If I try the cut option, my settings options change.

As you can see the circle becomes hollow and only the perimeter will be marked. Also the speed maximum is reduced to 500, and I no longer have a “lines per cm” resolution setting. Regardless, I’m going to try it… aaaand it was so fast I couldn’t even a chance to record it… lowering the speed setting from 500 to 200… and that seemed to work better… I was able to get a sense that the laser remained engaged at full power while the laser head swirled around in a circle over the Titan… but again very fast and not much of a mark left… so I’m going to drop it way way down to 50 and try again… but oh… nope… 100 is the slowest… so let’s make it run at 100 but do the max number of passes (3)… and now we have a result… but not a great result.

  1. The set focus process worked fine for the fiducials but not for the small Titan. You can see clearly in the video that the laser is way off target. I think this has to do with the fact the Titan is so very small and it’s likely that setting the focus measurement tooling on the print head probably has it’s own minimum area it can work with… and setting the focus target by manually dragging a reticle over such a tiny object is probably problematic at best.

  2. It is my hunch that somewhere between uploading the solid circle SVG to the design tool, and the actual engraving process being communicated to the Glowforge, somehow it is creating a halftone or some other type of pattern, which is why the laser is not remaining 100% engaged while passing over the target area.

So the alignment off by just a fraction… but it’s enough to totally overshoot such a small target. Also, I killed this Titan.

The power was enough to ablate the surface, but also heat the core beyond Curie temperature. This poor guy now measures only 0.1kGs even after fully cooling down to room temperature.

The bottom line

I think the accuracy of the Glowforge’s camera system is ultimately very very good and more than perfect enough for makers and producers… it just isn’t accurate enough for doing what we need.

At this point I think it’s possible that we will not be marking any Titans. I will put a poll up in the official Titan thread about this and sort out a solution if there are people who are willing to wait to sort out a solution after the holidays in 2021.


Just to have a bit of fun and try out the engraving feature some more, I decided to upload a PNG of the DT logo to the design tool and see if I could mark the titanium sheet I got for putting Titans on.

I immediately noticed the “greyscale” section under material settings… this was new and not shown for the SVG I uploaded…


So I changed it from “convert patterns” to vary power… so ideally the solid black of the logo would translate to 100% power. I also set the “minimum power” from 0 to 100… hoping to force it to 100% power. Finally, I also bumped up the lines per cm to the max 535 option… we’re goin for full quality here!

Ok so let me just do the set focus… and hit print… and in a few minutes I’ll have a … oh… 34 minutes!?

yeah… that is … goin slooowww… lots of lines there…

We’ll see what it looks like when it’s done… but for now I am thinking about the bitmap settings and how the default is to convert the bitmap to a “patterns”… or maybe it was dots… I don’t remember now… but either way, the question remains… is the solid circle SVG that I uploaded during the test above being converted into a pattern by default, even though there is no setting for this in the UI (because it’s a vector, not a bitmap)… so like… is the UI going “Ah ok it’s a vector so don’t show bitmap settings” but then the backend is going “default settings got it… converting to patterns”… ? maybe? dunno.

1 Like

I use a Red Sail laser, not a GlowForge so there may be some differences. In my experience, “cut” is meant to cut clean through a material, ie “cut this circle out of that piece of wood”. So that part of what you are seeing makes sense. The only settings for a cut are speed and power.

A bitmap could either be dithered (converted to dots) or greyscaled and vary power based on black level, which appears to be the option you found in that last post.

So what we’re seeing different then is how the vector fill is being treated. On the software I use, when you import a vector, each shape/object can be set to a color, and that color translates to a cut or etch command. So you might do the Dangerous Things logo in outline (not black filled) and make those lines blue, with a red circle around it then set blue to be etch at foo speed and bar power, and red means cut at baz speed and qux power. On my software, the etch setting you can set “x-swing” or “y-swing” which is just if you want the laser lines horizontal or vertical basically, but there is no pattern or dithering.

I don’t know if any of this is helpful at all, but it’s pretty cool that you are trying to make this work out. That poor dead magnet. Pour one out for sacrifices made in the name of science.


example: on my software, and again this may be different, I might set red to be “etch at speed 100 and power 80” and the black to be “cut at speed 50 power 100”. The grey fill means nothing to my laser, it’s just there for my own benefit picturing the result. Those settings will etch the design, say maybe 1/4 of the way into the material, then cut that piece out for me

1 Like

So after all that, you can barely make out the logo on the titanium surface. I think it actually just cleaned the surface off hahah!

I’m going to run it again without looking at it under the microscope just yet… but slower, and with fewer lines per cm… speed 200 and LPC 180…

hmm still not much change… dropping down to 100…

Ok this seems strange to me… the difference in actual physical speed of the laser head between 250 and 100 appears to be orders of magnitude different than say 250 and 1000… this is significantly slower than the previous runs.


Well I now think the Amazon seller sent me stainless steel plate instead of titanium… the laser is basically doing nothing to it.

You can see moments the laser is engaged (the tube is florescing) and nothing is happening on the plate. Couple that with the fact it’s really not marking anything… I think the rare moments the laser is visible reflecting off the plate itself is when a contaminant on the plate is being blasted. Under a microscope you can’t make out any difference between the barely visible logo image and the unmarked plate. I think the laser was just acting as an expensive and slow cleaning system hah!

I’ve been using some $20k+ 75W CO2 lasers for years at work. Metal marking is pretty much a no go with CO2 and we’ve always been recommended buying a Fiber laser for any kind of metal etching. With the CO2 you need to use a metal marking spray that bakes into the surface. Which probably eliminates any kind of sterility, since I’m pretty sure it’s an additive process.

Every couple years my boss asks about the sprays and I have to spend a day playing with power & speed ratios to get a somewhat readable result. There tends to be a lot of scatter/blur with the raster(left/right), making fine details really difficult. Vector cutting will allow finer details but only give you the outline of the logo.

Hitting tiny targets also sucks. Even at our price range the 0,0 on the tables rulers isn’t consistent, every time it boots up the homing sensors will be slightly off, only a fraction of a mm, but noticeable on something like the Titan. If I need to hit something tiny I cut out a slot in a scrap of acrylic for the piece or jig to drop into and make a new slot the next day. With the camera system on the Glowforge I’m guessing there is no 0,0 at all. :frowning:

Basically don’t feel bad about giving up marking the Titan. This thread is giving me slight PTSD and I’ve been using them for 20 years.


Forgive my ignorance, but doesn’t the ability to laser-etch metal depend a lot on the surface finish? I would think you might stand a chance if the finish is a bit rough (and the final outcome might be difficult to control depending on the roughness). But if it’s a mirror finish, doesn’t most of the light essentially bounce off the surface?