“Tag not compatible” while writing to new xSIID implant

Hello there- first time posting in the forums after an intermediate amount of lurking!

On to the issue though-

I have a new DT xSIID implant (standard location, healed for about 4 weeks, self install- no issues with healing and minimal migration) which has overall been doing quite well. It is well healed and blinking perfectly. I am having trouble figuring out how to write information to it though.

I intend to eventually use it as a business card and link it to my portfolio website, which has still at this point to be set up- but for now I planned on linking it to my twitter. However, I haven’t been able to get any of the apps I tried to reliably write the link to the chip.

I have an iphone 8, running IOS 15.2 and have tried NXP tagwriter and NFC Tools, as I have seen recommended. I also saw that apple devices tend to not like to write to chips, so I tried what I think I remember to be NXP tagwriter on my friends android as well. But I keep getting an error message stating that the “NFC tag is not supported” on both devices I have tried.

I was able to get my Iphone to write a link to an Imgur folder one time, right after installation (I THINK it was the NXP app that did it) but when I was screwing around and trying to replace the link with some nonsense youtube clip, I stopped being able to access the original imgur link (as expected) but also couldnt upload anything new. I hadn’t been Erasing anything from the chip in between attempts to upload data to it (which I did attempt to do more than a few times) so I am suspicious that the chip is holding on to the data from a dozen or so failed writing attempts and is acting funny because of that? I am still, however, unable to erase anything from the chip (same “not compatible” message as with writing).

My apologies for the newbish question (I am much more well versed in the biology part than the technology aspect) but does anyone know what is up with that? I appreciate any feedback in advance, and let me know if I can provide any more details abt my situation!)

Welcome from out of the shadows.

no need, that’s what the forum is for.

Have you tried using Format with either Tagwriter or NFC Tools?

let me know if you need screenshots or more info.

You should also check the location of the NFC antenna on your phone, I’ve seen that error when things are not aligned properly and it’s seems to be more important when writing. You can always use the xFD keychain to check this.

This thread also contains information about many phones: